Project

General

Profile

Bug #13163

Search for modules does not work, only first 20 modules available for CV

Added by Andreas Pfaffeneder about 3 years ago. Updated 8 months ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Content Views
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Centos 7.2, x86_64, all updates applied as of today, selinux restrictive.

katello-certs-tools-2.4.0-1.el7.noarch
katello-common-2.4.0-7.el7.noarch
pulp-katello-0.4-3.el7.noarch
katello-selinux-2.2.2-1.el7.noarch
tfm-rubygem-hammer_cli_katello-0.0.18-3.el7.noarch
tfm-rubygem-katello-2.4.0-3.el7.noarch
katello-2.4.0-7.el7.noarch
katello-repos-2.4.0-5.el7.noarch
katello-default-ca-1.0-1.noarch
katello-debug-2.4.0-7.el7.noarch
katello-installer-2.4.0-1.rc3.el7.noarch
katello-service-2.4.0-7.el7.noarch
katello-server-ca-1.0-1.noarch
katello-installer-base-2.4.0-1.rc3.el7.noarch

as plugin for the recent stable foreman:

foreman-release-scl-1-1.el7.x86_64
foreman-selinux-1.10.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.el7.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_10.el7.noarch
foreman-debug-1.10.0-1.el7.noarch
foreman-release-1.10.0-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
foreman-1.10.0-1.el7.noarch
foreman-compute-1.10.0-1.el7.noarch
foreman-postgresql-1.10.0-1.el7.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-foreman-tasks-0.7.10-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-libvirt-1.10.0-1.el7.noarch
foreman-vmware-1.10.0-1.el7.noarch
foreman-proxy-1.10.0-1.el7.noarch
foreman-gce-1.10.0-1.el7.noarch
foreman-ovirt-1.10.0-1.el7.noarch

I have added forge.puppetlabs.com as a repository for puppet module, a sync seems to be working, more than 3.8k modules available in my installation. Although the sync works and the modules are available, I only can select the first 20 (as sorted alphabetically) when trying to add modules to a CV. When one module is added, the 21st, then 20th module is available also. Searching does not work.


Related issues

Is duplicate of Katello - Bug #15435: Unable to add puppet module stdlib to my content view through the UIClosed2016-06-16

History

#1 Updated by Thomas McKay about 3 years ago

  • Bugzilla link set to 1309357

#2 Updated by Thomas McKay about 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Thomas McKay

#3 Updated by Justin Sherrill about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 113 to 150

#4 Updated by Justin Sherrill almost 3 years ago

  • Legacy Backlogs Release (now unused) changed from 150 to 144

#5 Updated by Eric Helms almost 3 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#6 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) changed from 168 to 171

#7 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) deleted (171)

#8 Updated by Justin Sherrill over 2 years ago

  • Status changed from Assigned to Duplicate
  • Priority changed from Normal to High

#9 Updated by Justin Sherrill over 2 years ago

  • Is duplicate of Bug #15435: Unable to add puppet module stdlib to my content view through the UI added

#10 Updated by Eric Helms over 2 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF