Project

General

Profile

Bug #13286

After upgrade to foreman 1.10 my smart proxy is no anymore sync and is only sending resetting dropped connection

Added by Mario Gamboa about 3 years ago. Updated 7 months ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Jan 19 22:53:06 awscapsule01 pulp: requests.packages.urllib3.connectionpool:INFO: Starting new HTTPS connection (1):
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - 'ConnectionClosed' object has no attribute 'url'
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - Traceback (most recent call last):
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/model.py", line 39, in fn
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - return fn(*args, **keywords)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/model.py", line 842, in send
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - self._impl.send(address, signed, ttl)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/proton/reliability.py", line 44, in _fn
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - return fn(messenger, *args, **kwargs)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/proton/reliability.py", line 64, in _fn
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - return fn(sender, *args, **kwargs)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/proton/producer.py", line 99, in send
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - sender = self.connection.sender(address)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/proton/connection.py", line 125, in sender
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - return self._impl.create_sender(address, name=name)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/utils.py", line 203, in create_sender
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - return BlockingSender(self, self.container.create_sender(self.conn, utf8(address), name=utf8(name), handler=handler, options=options))
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/utils.py", line 67, in init
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - super(BlockingSender, self).
_init__(connection, sender)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/utils.py", line 36, in init
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - msg="Opening link %s" % link.name)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/utils.py", line 231, in wait
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - self.container.process()
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/__init__.py", line 3729, in dispatch
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - ev.dispatch(self.handler)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/__init__.py", line 3654, in dispatch
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - result = dispatch(handler, type.method, self)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/__init__.py", line 3543, in dispatch
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - return m(*args)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/utils.py", line 254, in on_connection_remote_close
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - raise ConnectionClosed(event.connection)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - File "/usr/lib64/python2.7/site-packages/proton/utils.py", line 178, in init
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - txt = "Connection %s closed" % self.url
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.messaging.adapter.model:43 - AttributeError: 'ConnectionClosed' object has no attribute 'url'
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - send (progress), failed
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - Traceback (most recent call last):
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - File "/usr/lib/python2.7/site-packages/gofer/agent/rmi.py", line 239, in report
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - details=self.details)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - File "/usr/lib/python2.7/site-packages/gofer/messaging/adapter/model.py", line 44, in _fn
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - raise ModelError(*e.args)
Jan 19 22:53:06 awscapsule01 goferd: [ERROR][worker-0] gofer.agent.rmi:241 - ModelError: 'ConnectionClosed' object has no attribute 'url'
Jan 19 22:53:06 awscapsule01 pulp: requests.packages.urllib3.connectionpool:INFO: Resetting dropped connection:
Jan 19 22:53:06 awscapsule01 pulp: requests.packages.urllib3.connectionpool:INFO: Resetting dropped connection:

History

#1 Updated by Dmitri Dolguikh about 3 years ago

  • Status changed from New to Need more information

The backtrace you provided is for pulp, not smart-proxy. If you are seeing an issue with smart-proxy, please provide details, preferably with debug-level logs. If the issue is with pulp, you will need to contact the pulp team with it.

#2 Updated by Dominic Cleal about 3 years ago

  • Project changed from Smart Proxy to Katello

#4 Updated by Mario Gamboa about 3 years ago

Bufix works :)

#5 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) set to 113

#6 Updated by Mario Gamboa almost 3 years ago

This is solved on 2.4 with the new version of qpid-0.12 :)

#7 Updated by Eric Helms almost 3 years ago

Mario,

Can you provide the 'rpm -qa | grep qpid' and 'rpm -qa | grep kombu' for your packages? We are trying to understand if the version we shipped fixed it or if you installed a different version that fixed it.

#8 Updated by Mario Gamboa almost 3 years ago

Hi Eric here is my packages just to let you i found the issue was with the qpid version so i take the freedom to update to the version that fix the issue and currently the issue is fixed because if a try the latest version the goferd client on the capsule die can't starting up and is no working but with the 0.12 version all is back and running smooth just to let you know

qpid-proton-c-0.12.0-.el7.centos.x86_64
python-qpid-qmf-0.30-5.el7.x86_64
qpid-tools-0.30-4.el7.noarch
qpid-dispatch-router-0.4-10.el7.x86_64
python-gofer-qpid-2.6.2-1.el7.noarch
awscapsule01.test.aws.syd.vficonnect.internal-qpid-client-cert-1.0-1.noarch
qpid-qmf-0.30-5.el7.x86_64
awscapsule01.test.aws.syd.vficonnect.internal-qpid-router-server-1.0-1.noarch
awscapsule01.test.aws.syd.vficonnect.internal-qpid-router-client-1.0-1.noarch
qpid-cpp-server-linearstore-0.30-7.proton.0.9.el7.x86_64
awscapsule01.test.aws.syd.vficonnect.internal-qpid-broker-1.0-1.noarch
libqpid-dispatch-0.5-0.el7.centos.x86_64
python-qpid-proton-0.12.0-.el7.centos.x86_64
python-qpid-0.30-6.el7.noarch
qpid-cpp-client-0.30-7.proton.0.9.el7.x86_64
qpid-cpp-server-0.30-7.proton.0.9.el7.x86_64
python-kombu-3.0.24-8.pulp.el7.noarch

#9 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Need more information to Assigned
  • Assignee set to Justin Sherrill

#10 Updated by Sameer Syed almost 3 years ago

I am having the same issue after I upgraded to katello 2.4, running on RHEL 6.7. I see a comment above that this is fixed in 2.4, but like I said I upgraded to 2.4. How do you apply the bug fix provided above?

#11 Updated by Justin Sherrill almost 3 years ago

Katello 2.4.1 should be released in the next day or two with updated qpid packages. These new packages should resolve the issue.

#12 Updated by Justin Sherrill almost 3 years ago

  • Status changed from Assigned to Closed

As part of katello 2.4.1 we are updating a new qpid stack with a bunch of bug fixes around stability. I think this will fix a ton of the qpid related issues we are seeing including this one. Could you try out this release when it is out and give it a try?

The updated packages include:

libqpid-dispatch x86_64 0.4-11.el7
python-qpid noarch 0.30-9.el7
qpid-cpp-client x86_64 0.30-8.el7
qpid-cpp-client-devel x86_64 0.30-8.el7
qpid-cpp-server x86_64 0.30-8.el7
qpid-cpp-server-linearstore x86_64 0.30-8.el7
qpid-dispatch-router x86_64 0.4-11.el7
qpid-proton-c x86_64 0.9-13.el7

I will go ahead and close. Please re-open if you continue to have the issue after 2.4.1 is released and you have tried these updated packages.

Thanks!

#13 Updated by Mario Gamboa almost 3 years ago

Fixed all the issues Justin is great ;)

Also available in: Atom PDF