Project

General

Profile

Bug #13382

Removing a content view with an associated activation key

Added by A P over 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Content Views
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

When I tried to remove a content view that had an activation key associated with it, displayed an error saying you must disassociate first. Then I tried to open up the Activation Key page and it displayed an error.
From this point on I could not load the Activation Key page at all.
Jsheril's script helped me overcome the issue and it is located at https://gist.github.com/jlsherrill/323d4a47753b62a623f1.

Katello version as seen from the "About" katello-2.4.0-7.el6.noarch


Related issues

Is duplicate of Katello - Bug #12984: Can't delete activation keyClosed2016-01-04

History

#1 Updated by Justin Sherrill over 6 years ago

Error when attempting to use workaround: ActiveRecord::InverseOfAssociationNotFoundError: Could not find the inverse association for
pool_activation_keys (:activation_keys in Katello::PoolActivationKey)

#2 Updated by Justin Sherrill about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 113 to 150

#3 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 150 to 144

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (168)

#6 Updated by Justin Sherrill almost 6 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) set to 166

#7 Updated by Justin Sherrill almost 6 years ago

  • Is duplicate of Bug #12984: Can't delete activation key added

Also available in: Atom PDF