Project

General

Profile

Feature #13402

Foreman Parameters & Salt Multilevel Pillars

Added by Alex Smith over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

It will be grate, if foreman will be support Salt multilevel pillar names in parameters.

For Example:

open_vm_tools:
lookup:
disabled: False
package: open-vm-tools
service: vmtoolsd

This type of pillar structure is very useful with construction like:

{% set open_vm_tools = salt['grains.filter_by']({
'Debian': {
'package': 'open-vm-tools',
'service': 'vmtools',
},
'RedHat': {
'package': 'open-vm-tools',
'service': 'vmtoolsd',
},
'Arch': {
'package': '...',
'config': '...',
},
}, merge=salt['pillar.get']('open_vm_tools:lookup')) %}


Related issues

Related to Foreman - Feature #4127: Array, Boolean and other types support in "hostgroup parameters"Closed

History

#1 Updated by Dominic Cleal over 4 years ago

  • Project changed from Foreman to Salt
  • Category deleted (Web Interface)

#2 Updated by Stephen Benjamin over 4 years ago

  • Status changed from New to Duplicate

Basically a dupe of #4127, this is entirely up to Foreman core to support it - and it's coming, hopefully sooner rather than later. Eventually parameters will support complex data like hashes (and merging of hashes down the hierarchy).

There's also http://projects.theforeman.org/issues/8413, which is an eventual goal as well, to support things like attaching particular parameters to particular states, like you can with Smart Variables with Puppet.

#3 Updated by Stephen Benjamin over 4 years ago

  • Related to Feature #4127: Array, Boolean and other types support in "hostgroup parameters" added

Also available in: Atom PDF