Project

General

Profile

Bug #13493

Docker plugin missing sass dependency after fresh install for Foreman 1.10.1 on CentOS 7.2

Added by Brandon Merjil over 3 years ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Docker
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

I completed a fresh install of Foreman 1.10.1 on CentOS 7.2 with the Docker plugin included using the katello-deploy scripts.
I attached a computer resource and then tried to create new container.
Resource selection had the correct information displayed, but when next was clicked the following error appeared:
cannot load such file -- sass (in /opt/theforeman/tfm/root/usr/share/gems/gems/katello-2.4.0/app/assets/stylesheets/katello/containers/container.scss)

I found that the ruby193-rubygem-sass rpm was not installed.
After installing the package I was able to create a new container.


Related issues

Is duplicate of Katello - Bug #13214: Asset katello/containers/container.css is not precompiledClosed2016-01-14

History

#1 Updated by Dominic Cleal over 3 years ago

  • Project changed from Docker to Katello
  • Category deleted (Plugin (foreman_docker))

This is a bug in Katello, the file should be precompiled alleviating the need for the sass dependency. I think it was fixed in #13214.

#2 Updated by Brandon Merjil over 3 years ago

Ok so future release will have it precompiled.

Thaks.

#3 Updated by Eric Helms over 3 years ago

  • Category set to Docker
  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) set to 114

#4 Updated by Eric Helms over 3 years ago

  • Is duplicate of Bug #13214: Asset katello/containers/container.css is not precompiled added

Also available in: Atom PDF