Project

General

Profile

Bug #13520

katello-installer/hooks/pre/30-upgrade.rb points to wrong path for monodb config

Added by Matthias Thubauville over 3 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The path for the in the MongoDB Configuration in 30-upgrade.rb hook points to

/etc/mongodb.conf

However on EL7 the file is stored at
/etc/mongod.conf

This results in the following error message during execution of the hook

[ERROR verbose] Repeating errors encountered during run:
[ERROR verbose] sed: can't read /etc/mongodb.conf: No such file or directory

Changing the path in 30-upgrade.rb seems to fix the issue.

Associated revisions

Revision f8884f07 (diff)
Added by Matthias Thubauville over 3 years ago

Fixes #13520 - Use correct mongod.conf path in 30-upgrade hook for EL7

Revision 3e54a610
Added by Eric D Helms over 3 years ago

Merge pull request #294 from Thubo/master

Fixes #13520 - Use correct mongod.conf path in 30-upgrade hook for EL7

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello-installer/pull/294 added

#2 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 86

#3 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF