Project

General

Profile

Support #13570

host.hostgroup search does not allow to search parent hostgroups

Added by Jeff Sparrow almost 6 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Search
Target version:
-
Triaged:
No
Fixed in Releases:
Found in Releases:

Description

If you have some host groups like:

/hostgroup/foobar/apple/banna

If you have hosts in any of the parents, you can not filter for facts.
eg; you can not use:

host.hostgroup ~ apple
host.hostgroup ~ foobar
host.hostgroup ~ hostgroup

it will only allow calls to
host.hostgroup ~ banana

This means if you have shared hostgroups where multiple teams might share, they can not filter for facts.
eg;

/Corporate/IT/NetworkTeam/
host1
host2
/Corporate/IT/NetworkTeam/foobar
host3
host4

because foobar now exists, searches into /Corporate/IT/NetworkTeam will fail.

The fact searching should be done the same as host searching with:
hostgroup_fullname ~


Related issues

Is duplicate of Foreman - Feature #6116: search hosts by parent host group and its decendantsClosed2014-06-09

History

#1 Updated by Dominic Cleal almost 6 years ago

  • Is duplicate of Feature #6116: search hosts by parent host group and its decendants added

#2 Updated by Dominic Cleal almost 6 years ago

  • Status changed from New to Feedback
  • Assignee deleted (Daniel Lobato Garcia)

Use host.parent_hostgroup = apple

#3 Updated by Anonymous over 4 years ago

  • Tracker changed from Feature to Support
  • Status changed from Feedback to Resolved

Also available in: Atom PDF