Project

General

Profile

Bug #13595

Storage domain dropdown menu doesn't work

Added by Diego Michelotto over 6 years ago. Updated over 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Compute resources - oVirt
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Dear support team

when I try to create a new VM with foreman on oVirt I cannot able to select an storage domain from the dropdown menu because it doesn't work.

As you can see from the next image if I select the dropdown menu nothing is displayed

Viewing the source code I found 2 elements for the dropdown menu, asu you can see from the next image:

If I delete the first element and remove "display: none" from the style parameter, as you can see in the next image:

Al works fine, as you can see in the next image:

Best regards
Diego

code_right.png View code_right.png 15.7 KB Diego Michelotto, 02/08/2016 04:56 AM
storage_domain_ok.png View storage_domain_ok.png 19.6 KB Diego Michelotto, 02/08/2016 04:56 AM
code_wrong.png View code_wrong.png 19.5 KB Diego Michelotto, 02/08/2016 04:56 AM
storage_domain_broken.png View storage_domain_broken.png 14.7 KB Diego Michelotto, 02/08/2016 04:56 AM
Code right Storage domain ok Code wrong Storage domain broken

Related issues

Related to Foreman - Bug #14041: VM provisioning : dropdown lists greyed out in new volume fieldsClosed2016-03-03

History

#1 Updated by Dominic Cleal over 6 years ago

  • Category changed from Web Interface to Compute resources - oVirt
  • Priority changed from Urgent to Normal

#2 Updated by Doina Cristina Aiftimiei over 6 years ago

Same problem here and is... blocking.
Working with workarounds is not a clean way to go.

#3 Updated by Ben Bettridge over 6 years ago

If you view a host that already has disks attached to it, then the form works correctly. Might indicate that the issue is in whatever code generates the form on the page.

Had a look through the code, but I can't really make heads or tails of where this all happens.

#4 Updated by Ben Bettridge over 6 years ago

Dug through it some more. At runtime the template is generated correctly (without the extra div), but on the page it is stored incorrectly in the DOM. It appears not to be an issue with the template generation, but instead with what ever process is adding it to the DOM, under children_fields. This is a pretty critical bug because it more or less prevents people from building out virtual machines - is anyone else looking at it?

This bug impacts VMWare Plugin, oVirt Plugin and a version of the Xen Plugin.

#5 Updated by Diego Michelotto over 6 years ago

The bug still exist in the 1.10.2 release.

Regards
Diego

#6 Updated by Angelo Lisco over 6 years ago

Unluckily, even if the foreman interface was migrated to Patterfly, the bug is still present in 1.11RC1 release.
I think this should be fixed before 1.11 GA.

#7 Updated by Anonymous over 6 years ago

  • Legacy Backlogs Release (now unused) set to 71

As this seems to be a general bug that's hitting multiple compute resource types, somebody should have a look.

#8 Updated by David Rom over 6 years ago

  • Related to Bug #14041: VM provisioning : dropdown lists greyed out in new volume fields added

#9 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) deleted (71)

This should be fixed by the changes under ticket #14041, which are currently in review and anticipated to be included in 1.10.3. This means they will probably be in 1.11.0 too, depending on the timing. Thanks for the report!

Also available in: Atom PDF