Project

General

Profile

Bug #13695

OSTree repositories show wrong published at URL

Added by Partha Aji over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

On ostree repo create, the UI's published at URL points to -> http://<fqdn>/pulp/repos/<Org>/Library/custom/<Product>/<Repo> . What needs to get displayed instead is https://<fqdn>/pulp/ostree/web/<Org>/Library/custom/<Product>/<Repo>

We may need to add a http redirect alias in /etc/pulp/vhosts80/ostree.conf if we need http.


Related issues

Blocks Katello - Tracker #10034: Atomic Content & Provision Support Katello/ForemanNew

Associated revisions

Revision a0a214d9
Added by Partha Aji over 3 years ago

Merge pull request #5858 from parthaa/branches-model

Fixes #13695,11612 - Shows ostree branches for a repo

History

#1 Updated by Partha Aji over 3 years ago

  • Blocks Tracker #10034: Atomic Content & Provision Support Katello/Foreman added

#2 Updated by Eric Helms over 3 years ago

  • Subject changed from Need fix published at URL for OSTree to OSTree repositories show wrong published at URL
  • Legacy Backlogs Release (now unused) set to 86

#3 Updated by David Davis over 3 years ago

  • Assignee set to David Davis

#4 Updated by Partha Aji over 3 years ago

  • Assignee changed from David Davis to Partha Aji
  • Pull request https://github.com/Katello/katello/pull/5842 added

#5 Updated by Partha Aji over 3 years ago

  • Status changed from New to Ready For Testing

#6 Updated by The Foreman Bot over 3 years ago

  • Pull request https://github.com/Katello/katello/pull/5858 added

#7 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF