Project

General

Profile

Feature #1371

Re-query the abilities of the proxy

Added by Ashley Penney about 10 years ago. Updated about 9 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Currently once you've added a proxy it does some initial discovery to decide what it manages. If you need to change that (say to remove dhcp management) you have to remove the entire proxy and readd it to make Puppet aware those roles have changed. This can be a pain and it would be nice to issue some kind of rediscover command that checked all the proxies for current roles. Or they reported in every so often, whatever works.


Related issues

Is duplicate of Foreman - Feature #1244: smart proxies overview page needs a button to 're-read' the supported features of a proxyClosed2011-10-20

History

#1 Updated by Ohad Levy about 10 years ago

  • Target version set to 1.0

i can see hows thats confusing.

btw: an easier solution is to edit the proxy and hit save again.

#2 Updated by Ohad Levy over 9 years ago

  • Target version deleted (1.0)

#3 Updated by Benjamin Papillon about 9 years ago

  • Status changed from New to Duplicate

This issue has already been reported. I'm closing this ticket.

If you feel this is an error, don't hesitate to reopen it!

Also available in: Atom PDF