Project

General

Profile

Bug #13711

Can't create new subnet with domain

Added by Marek Hulán over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Database
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

When I try to create new subnet and select some domain, it does not get saved and it unchecks the selected domain. It does not display any error message, but in logs (and through hammer) an error about invalid :subnet_domains relation can be found. It's caused by validations on relation entity which does not have foreign id, since we are about to save the new record. IMHO validations on relation entity should be removed, we never use the class directly and rely on active record to create it.


Related issues

Related to Foreman - Bug #23164: (some) subnet validation errors are not shownNew
Has duplicate Foreman - Bug #13940: Subnet creation with associated domains fails (hammer cli)Duplicate2016-02-29

Associated revisions

Revision 46eec8ba (diff)
Added by Marek Hulán over 3 years ago

Fixes #13711 - fix subnet/domain validation during creation

Revision 4a5d57a1 (diff)
Added by Marek Hulán over 3 years ago

Fixes #13711 - fix subnet/domain validation during creation

(cherry picked from commit 46eec8ba4163a8f237b3189f43d2f873a2267288)

History

#1 Updated by Marek Hulán over 3 years ago

looks related to #12866 but I think it's a different issue, since it possible to fix it through webui - which is not the case here

#2 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3186 added

#3 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 71

#4 Updated by Dominic Cleal over 3 years ago

  • Has duplicate Bug #13940: Subnet creation with associated domains fails (hammer cli) added

#5 Updated by Marek Hulán over 3 years ago

  • Bugzilla link set to 1313858

#6 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Marek Hulán over 1 year ago

  • Related to Bug #23164: (some) subnet validation errors are not shown added

Also available in: Atom PDF