Project

General

Profile

Bug #13718

Unable to select various tabs under puppetca tab of smart-proxy

Added by Kedar Bidarkar over 6 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

On the smart-proxy show page, we have the "Puppet CA" Tab, which in-turn has these below tabs.

a) General
b) Certificates
c) Autosign entries

The above tabs do not get loaded currently upon clicking them.


Related issues

Related to Foreman - Bug #14679: smart proxy puppet CA sub-tabs missing data-toggle="tab"Closed2016-04-17
Has duplicate Katello - Bug #14484: Unable to select various tabs under puppetca tab of smart-proxyDuplicate2016-04-05

Associated revisions

Revision 5e646d60 (diff)
Added by Walden Raines over 6 years ago

Fixes #13718: call foreman setTab() on non-content pages.

Fix the dropdown menu not working by calling the foreman setTab()
function when a route does not match the content routes.

http://projects.theforeman.org/issues/13718

Revision 9cf5478e
Added by Walden Raines over 6 years ago

Merge pull request #5992 from waldenraines/13718

Fixes #13718: call foreman setTab() on non-content pages.

History

#1 Updated by Dominic Cleal over 6 years ago

  • Status changed from New to Need more information

Please check for errors in your browser's console, and ensure you're running the latest develop commit. I can't reproduce this on develop or in nightly packages.

#2 Updated by Kedar Bidarkar over 6 years ago

I tried with firefox browser and the nightly (2016-02-22 installed) with katello+foreman

I see the below error in the browser:

Error: [$injector:unpr] Unknown provider: eProvider <- e
http://errors.angularjs.org/1.2.9/$injector/unpr?p0=eProvider%20%3C-%20e
r/<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:14773
Ot/$.$injector<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:30308
n@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29573
Ot/x.$injector<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:30401
n@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29573
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29858
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:4:32730
m/this.when/s.matcher/<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:5:511
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:5:1054
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:5:1167
kn/this.$get</c.prototype.$broadcast@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:3185
l@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:2:23783
fn/this.$getkn/this.$get</c.prototype.$eval@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:1954
kn/this.$get</c.prototype.$digest@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:654
kn/this.$get</c.prototype.$apply@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:2275
fn/this.$getit.event.dispatch@https://abc.redhat.com/assets/application-9e1b8cb558d4244d3c0ba8e714ce09141fae0a7417e5c7c02a4adeb3014b4078.js:26:1060
it.event.add/g.handle@https://abc.redhat.com/assets/application-9e1b8cb558d4244d3c0ba8e714ce09141fae0a7417e5c7c02a4adeb3014b4078.js:25:30738

This issue is also seen in latest stable chrome version : 48.0.2564.116 (64-bit)

#3 Updated by Dominic Cleal over 6 years ago

  • Project changed from Foreman to Katello
  • Category deleted (Smart Proxy)
  • Status changed from Need more information to New

Tentatively moving this to Katello due to the location of the error.

#4 Updated by Eric Helms over 6 years ago

  • Category set to Web UI
  • Assignee set to Walden Raines
  • Legacy Backlogs Release (now unused) set to 86
  • Difficulty set to medium

#5 Updated by Tomer Brisker over 6 years ago

  • Related to Bug #14679: smart proxy puppet CA sub-tabs missing data-toggle="tab" added

#6 Updated by Tomer Brisker over 6 years ago

  • Is duplicate of Bug #14484: Unable to select various tabs under puppetca tab of smart-proxy added

#7 Updated by Walden Raines over 6 years ago

  • Status changed from New to Duplicate

Duplicate of #13718

#8 Updated by Walden Raines over 6 years ago

  • Status changed from Duplicate to Assigned

#9 Updated by Walden Raines over 6 years ago

  • Bugzilla link set to 1319278

#10 Updated by Walden Raines over 6 years ago

  • Project changed from Katello to Foreman
  • Category deleted (Web UI)
  • Assignee changed from Walden Raines to Tomer Brisker

#11 Updated by Walden Raines over 6 years ago

  • Assignee changed from Tomer Brisker to Walden Raines

#12 Updated by Dominic Cleal over 6 years ago

  • Project changed from Foreman to Katello

#13 Updated by Marek Hulán over 6 years ago

If this was duplicated by #14484 which is now merged - https://github.com/Katello/katello/pull/5938 I think this issue should be set to close (and link the PR). I guess the duplication was meant to be set other way around. I'm not moving it myself as I'm not confident about if this is 100% duplicity.

#14 Updated by Walden Raines over 6 years ago

  • Is duplicate of deleted (Bug #14484: Unable to select various tabs under puppetca tab of smart-proxy)

#15 Updated by Walden Raines over 6 years ago

  • Has duplicate Bug #14484: Unable to select various tabs under puppetca tab of smart-proxy added

#16 Updated by Walden Raines over 6 years ago

Marek Hulán wrote:

If this was duplicated by #14484 which is now merged - https://github.com/Katello/katello/pull/5938 I think this issue should be set to close (and link the PR). I guess the duplication was meant to be set other way around. I'm not moving it myself as I'm not confident about if this is 100% duplicity.

Yeah, I had them backwards and just fixed it, thanks!

#17 Updated by The Foreman Bot over 6 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5992 added

#18 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 144

#19 Updated by Walden Raines over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#20 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 86

Also available in: Atom PDF