Project

General

Profile

Bug #13726

pending puppet certificates can't be removed

Added by Ohad Levy over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Smart proxies
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

currently the UI allows to "revoke" a pending certificate - which makes no sense.
pending certs should only be signed or deleted.

also, clicking on revoke does not delete the certificate request.

(see attachment)

cert.png View cert.png 29.7 KB Ohad Levy, 02/16/2016 03:51 AM
Cert

Related issues

Related to Foreman - Feature #12720: As a User I would like to get puppet related data of the smart proxyClosed2015-12-07

Associated revisions

Revision 21f39c12 (diff)
Added by Shlomi Zadok over 3 years ago

Fixes #13726 - rename delete button on pending certs

History

#1 Updated by Ohad Levy over 3 years ago

  • Related to Feature #12720: As a User I would like to get puppet related data of the smart proxy added

#2 Updated by Michael Moll over 3 years ago

I guess this is a duplicate of #3995?

#3 Updated by Ohad Levy over 3 years ago

probably, but I would address the fix differently, as simply not showing that option in the drop down until the bug is fixed in puppet itself.

#4 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Shlomi Zadok
  • Pull request https://github.com/theforeman/foreman/pull/3197 added

#5 Updated by Shlomi Zadok over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal over 3 years ago

  • Legacy Backlogs Release (now unused) set to 71

#7 Updated by Bryan Kearney over 3 years ago

  • Bugzilla link set to 1201408

Also available in: Atom PDF