Project

General

Profile

Bug #13832

Both Matcher Value and puppet-default value can be set at a time in sc-param

Added by Jitendra Yejare almost 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Foreman commands (obsolete)
Target version:
-
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1310645
Description of problem:
Matcher value and puppet default can be set as matcher value for smart class parameter and at-a time. Actually If 'Use-puppet-default' option is checked for matcher, matcher value cannot be set from UI. And same is expected in CLI.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201602171602gitd5b5059.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Attempt to create matcher with override value and puppet default value at a time from CLI.
  1. hammer -u admin -p changeme sc-param add-override-value --match <match> --value <value> --use-puppet-default 1

Actual results:
Success! Both value and puppet default is set.

Expected results:
Either one is value is set or exception raised for wrong attempt.

Additional info:


Related issues

Related to Foreman - Bug #13727: Error not raised while setting default value when 'Override' set to False for parameter.Closed2016-02-16

Associated revisions

Revision 5456fe2a (diff)
Added by Tomas Strachota over 4 years ago

Fixes #13832 - Add one_of constraint for option validator

Revision def5d036 (diff)
Added by Tomas Strachota over 4 years ago

Fixes #13832 - Add support for testing values in option validation

Revision e226b3a4 (diff)
Added by adamruzicka over 4 years ago

Fixes #13832 - Forbid setting smart param override value and puppet default

History

#1 Updated by Dominic Cleal almost 5 years ago

  • Related to Bug #13727: Error not raised while setting default value when 'Override' set to False for parameter. added

#2 Updated by Dominic Cleal almost 5 years ago

  • Category set to Parameters

#3 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Adam Ruzicka
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/233 added

#4 Updated by The Foreman Bot over 4 years ago

  • Pull request https://github.com/theforeman/hammer-cli/pull/207 added

#5 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Adam Ruzicka over 4 years ago

  • Status changed from Closed to Ready For Testing

Moving back to ready for testing since https://github.com/theforeman/hammer-cli-foreman/pull/233 is still opened

#7 Updated by Dominic Cleal over 4 years ago

  • Project changed from Foreman to Hammer CLI
  • Category changed from Parameters to Foreman commands (obsolete)

#8 Updated by Anonymous over 4 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF