Project

General

Profile

Bug #13900

Bulk Actions in UI do not actually update CV/LE's for hosts

Added by Zac Durham over 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Hosts
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I have observed in 1.10.1 and in Sat 6.1.6 that despite assigning/reassigning content hosts to different content views or lifecycle environments using Bulk Actions and despite the new assignments showing correctly afterwards in 'Content Hosts', the redhat.repo files on those hosts remains unaffected- even after a 'subscription-manager refresh'. Manually (and somewhat painstakingly) assigning/reassigning each host individually in the UI does work.

I noticed this problem in production with Satellite 6.1.6. I had sets of systems, some that had been assigned to their intended CV/LE through some other means and some that had been assigned through Bulk Actions. I kept noticing the repolist counts were not in agreement between them and in fact they did have different views of the same content. After inspecting their redhat.repo files, validating they were not pointing to the inteded baseurl, and testing again to change their views using Bulk Action, I determined that was the issue.

Steps to reproduce:
1. Create a new Content View and promote to a Lifecycle Environemnt
2. Using Bulk Actions, assign a content host to this CV/LE
3. Run subscription-manager refresh on the content host
4. Observe the baseurl in redhat.repo is still pointing to the previously assigned CV/LE

History

#1 Updated by Dominic Cleal over 6 years ago

  • Project changed from Foreman to Katello

#2 Updated by Eric Helms about 6 years ago

  • Category set to Hosts
  • Legacy Backlogs Release (now unused) set to 86

#3 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 144

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (168)

#6 Updated by Justin Sherrill almost 6 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

This was resolved in Katello 3.0.

Also available in: Atom PDF