Project

General

Profile

Bug #13925

Bootstrap RPM generated on Puppet 3.6 does not configure CA cert properly

Added by Eric Helms over 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Associated revisions

Revision 23df3b4c (diff)
Added by Eric Helms over 4 years ago

Fixes #13925: Use concat to build reconfigure script

On Puppet 3.6 the use of File.read in the reconfigure template
causes the certs to be empty given the template is evaluated
at the beginning. This switches to concat to build up the reconfigure
script using the source parameter to read from the cert files.

Revision a79646c5
Added by Eric D Helms over 4 years ago

Merge pull request #77 from ehelms/fixes-13925

Fixes #13925: Use concat to build reconfigure script

History

#1 Updated by Eric Helms over 4 years ago

  • Pull request https://github.com/Katello/puppet-certs/pull/77 added

#2 Updated by Eric Helms over 4 years ago

  • Bugzilla link set to 1313076

#3 Updated by Eric Helms over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF