Project

General

Profile

Bug #13949

hammer --help page displays with warning : ruby-libvirt --version

Added by Tazim Kolhar about 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
medium
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

$ hammer --help
Ignoring ruby-libvirt-0.5.2 because its extensions are not built. Try: gem pristine ruby-libvirt --version 0.5.2
Usage:
hammer [OPTIONS] SUBCOMMAND [ARG] ...

Parameters:
SUBCOMMAND subcommand
[ARG] ... subcommand arguments

Subcommands:
activation-key Manipulate activation keys.
architecture Manipulate architectures.
auth Foreman connection login/logout.
auth-source Manipulate auth sources.
bootdisk Download boot disks
capsule Manipulate capsule
compute-resource Manipulate compute resources.
content-host Manipulate content hosts on the server
content-report View Content Reports
content-view Manipulate content views.
defaults Defaults management
docker Manipulate docker content
domain Manipulate domains.
environment Manipulate environments.
erratum Manipulate errata
fact Search facts.
filter Manage permission filters.
global-parameter Manipulate global parameters.
gpg Manipulate GPG Key actions on the server
host Manipulate hosts.
host-collection Manipulate host collections
hostgroup Manipulate hostgroups.
import Import data exported from a Red Hat Satellite 5 instance
lifecycle-environment Manipulate lifecycle_environments on the server
location Manipulate locations.
medium Manipulate installation media.
model Manipulate hardware models.
organization Manipulate organizations
os Manipulate operating system.
package Manipulate packages.
package-group Manipulate package groups
partition-table Manipulate partition tables.
ping Get the status of the server
product Manipulate products.
proxy Manipulate smart proxies.
puppet-class Search puppet modules.
puppet-module View Puppet Module details.
recurring-logic Recurring logic related actions.
report Browse and read reports.
repository Manipulate repositories
repository-set Manipulate repository sets on the server
role Manage user roles.
sc-param Manipulate smart class parameters.
settings Change server settings.
shell Interactive shell
smart-variable Manipulate smart variables.
subnet Manipulate subnets.
subscription Manipulate subscriptions.
sync-plan Manipulate sync plans
task Tasks related actions.
template Manipulate config templates.
user Manipulate users.
user-group Manage user groups.

Options:
--autocomplete LINE Get list of possible endings
--csv Output as CSV (same as --output=csv)
--csv-separator SEPARATOR Character to separate the values
--interactive INTERACTIVE Explicitly turn interactive mode on/off
One of true/false, yes/no, 1/0.
--output ADAPTER Set output format. One of [base, table, silent, csv, yaml, json]
--show-ids Show ids of associated resources
--version show version
-c, --config CFG_FILE path to custom config file
-d, --debug show debugging output
-h, --help print help
-p, --password PASSWORD password to access the remote system
-r, --reload-cache force reload of Apipie cache
-s, --server SERVER remote system address
-u, --username USERNAME username to access the remote system
-v, --verbose be verbose


Related issues

Is duplicate of Packaging - Bug #13948: ruby-libvirt error messages constantly displayed when using foreman-rake or hammerClosed2016-02-29

History

#1 Updated by Dominic Cleal about 3 years ago

  • Is duplicate of Bug #13948: ruby-libvirt error messages constantly displayed when using foreman-rake or hammer added

#2 Updated by Dominic Cleal about 3 years ago

  • Status changed from New to Duplicate

This issue is tracked under ticket #13948.

Also available in: Atom PDF