Project

General

Profile

Feature #13973

Add Support to get Host YAML output from CLI and API.

Added by Jitendra Yejare about 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
External Nodes
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1313354
Description of problem:
Add support to get the Host YAML output from CLI and API.
Currently we can see YAML output of Host only from UI.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
YAML output of host is only accessible from UI.

Expected results:
YAML output should be accessible from API as well CLI.

Additional info:


Related issues

Related to Foreman - Feature #3220: API for "rendered" view of host parameters, taking into account inheritanceNew2013-10-08
Is duplicate of Foreman - Feature #15926: Add a new endpoint to get ENC values of a hostClosed2016-08-01

History

#1 Updated by Dominic Cleal about 4 years ago

  • Related to Feature #3220: API for "rendered" view of host parameters, taking into account inheritance added

#2 Updated by Dominic Cleal about 4 years ago

  • Category set to External Nodes

#3 Updated by Dominic Cleal almost 4 years ago

  • Is duplicate of Feature #15926: Add a new endpoint to get ENC values of a host added

#4 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Duplicate

An API is added under ticket #15926.

Also available in: Atom PDF