Project

General

Profile

Bug #13985

official RHEL repositories can not be mixed with custom repositories

Added by Andreas Faust about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Category:
Activation Key
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Hi,
this is a Katello 2.3.1 Report.

we have own software in our own repository, and we have official RHEL Licenses in Katello.

The Setup is:
Own repository synced into Product
RHEL Synced into Product

A Content View on RHEL Product
A Content View on our Product

A Composite Content View which combines RHEL & Our Content View, which gets activated via a Hostgroup and Activation Keys.

If I subscribe a Host to the Composite View, subscription-manager repos only shows the official RHEL repos.
/etc/yum.repos.d/redhat.repo only knows about official RHEL repos

Manual "subscription-manager attach --pool <PoolID of our Repo>" makes the Repo listed as consumed, but it's still not used.

probably it's a PEBKAC issue, but documentation lacks how to do it, and I've been unable to find documentation how to do it right.

Thanks, Andreas

History

#1 Updated by Eric Helms about 6 years ago

  • Category set to Activation Key
  • Legacy Backlogs Release (now unused) set to 86

#2 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 144

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (168)

#5 Updated by Justin Sherrill almost 6 years ago

  • Assignee set to Zach Huntington-Meath
  • Difficulty set to easy

#6 Updated by Zach Huntington-Meath almost 6 years ago

  • Status changed from New to Closed

I tested this on my system and was unable to reproduce after following the instructions laid out. If you still encounter this problem, please reopen the ticket and give a little more detail on what steps you took to have this issue come up.

#7 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Closed to Rejected
  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF