Project

General

Profile

Bug #13988

Hostgroups Puppet Class management issue

Added by Andreas Faust about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
medium
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Good evening,
This is a Katello 2.3.1 Report

Having a Hostgroup completely configured ( no hosts attached ) shows no puppet modules on "Puppet Classes" Tab.
Going back to "Host Group" Tab, and clicking the "Reset Puppet Environment to match selected Content View" link, suddenly loads the Puppet Classes.
Nothing has been changed. just clicking this link made them available.

Pressing "Submit" and reentering the host group, the puppet classes are all gone again.
Foremans production.log does not show any error.

Thank you
Andreas


Subtasks


Related issues

Related to Foreman - Bug #11749: new host puppet environment jquery selector too liberalClosed2015-09-09

History

#1 Updated by Eric Helms about 6 years ago

  • Category set to 89
  • Legacy Backlogs Release (now unused) set to 86

#2 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 144

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#4 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (168)

#5 Updated by Justin Sherrill almost 6 years ago

  • Related to Bug #11749: new host puppet environment jquery selector too liberal added

#6 Updated by Justin Sherrill almost 6 years ago

  • Assignee set to David Davis
  • Difficulty set to medium

#7 Updated by David Davis almost 6 years ago

I tested this against Katello 3.0 and I couldn't reproduce. I did find another strange behavior for which I opened a bug:

http://projects.theforeman.org/issues/15867

#8 Updated by David Davis almost 6 years ago

  • Status changed from New to Rejected

Feel free to reopen if you can reproduce.

#9 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF