Project

General

Profile

Bug #13996

Hammer - Unable to create a read only user to dump templates

Added by Brad Buckingham over 5 years ago. Updated over 5 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1302789
Description of problem: Hammer - Unable to create a read only user to dump templates

Version-Release number of selected component (if applicable): 6.1.5

How reproducible:

Steps to Reproduce:
1. Create a role named example "testrole" select resource type Provisioning template and add all permissions (view_templates, create_templates, edit_templates, destroy_templates, deploy_templates, lock_templates)

2. Create a user named "test" and add roles testrole, View hosts, Viewer and View compliance reports.

3. Now login with user test and execute below commands to dump template.

  1. hammer list templates
    take a template id number which you want to dump.
  1. hammer -u test -p redhat template dump --id 41
    Resource config_template not found by id '41'

Test user gets an error "Resource config_template not found by id '41'" while dumping template.

Actual Result - It fails with above error.
Expected Result - It should dump without any error.


Related issues

Is duplicate of Foreman - Bug #9687: Provisioning Template Roles: view_template, edit_template doesn't render on 1.7.3 for non-adminClosed2015-03-09

History

#1 Updated by Dominic Cleal over 5 years ago

  • Is duplicate of Bug #9687: Provisioning Template Roles: view_template, edit_template doesn't render on 1.7.3 for non-admin added

#2 Updated by Dominic Cleal over 5 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF