Project

General

Profile

Bug #14021

Cannot create repository through CLI

Added by Eric Helms about 4 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
Category:
Hammer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Bats testing flagged the following failure which blocks the pipeline:

not ok 14 create package repository
# (in test file fb-content-katello.bats, line 21)
#   `--url https://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/ | grep -q "Repository created"' failed
# Could not create the repository:
#   Error: option '--content-type': value must be one of 'yum', 'docker', 'puppet', 'file'
#   
#   See: 'hammer repository create --help'

Related issues

Is duplicate of Katello - Bug #13960: Can't specify content type with --content-type flag when creating a repoClosed2016-02-29

History

#1 Updated by David Davis about 4 years ago

  • Status changed from New to Duplicate

#2 Updated by David Davis about 4 years ago

  • Is duplicate of Bug #13960: Can't specify content type with --content-type flag when creating a repo added

Also available in: Atom PDF