Project

General

Profile

Bug #14151

Smart proxy not syncing anymore after upgrade

Added by Sameer Syed about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Repositories
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I had upgraded katello from 2.3 to 2.4 version, one the bug fixes I was looking forward to was the sync issues between proxies and the katello server. In particular the qpid-dispatch router heartbeat that will keep the connection live between the smart proxies and the katello server. I was able to sync the capsules manually using hammer after restarting gofer. But after upgrade that is failing as well.

I've found a similar bug filed - Bug #13286 which mentions of the same issue, but the user reporting is running centos 7 and I am running RHEL 6.7. Logs are attached.

qpid packages installed on capsule:

rpm -qa | grep qpid
qpid-dispatch-router-0.4-10.el6.x86_64
python-gofer-qpid-2.6.2-1.el6.noarch
capsule.example.com-qpid-router-client-1.0-1.noarch
python-qpid-qmf-0.30-5.el6.x86_64
qpid-proton-c-0.9-2.el6.x86_64
qpid-cpp-server-linearstore-0.30-7.proton.0.9.el6.x86_64
capsule.example.com-qpid-broker-1.0-1.noarch
python-qpid-proton-0.9-2.el6.x86_64
qpid-qmf-0.30-5.el6.x86_64
qpid-tools-0.30-4.el6.noarch
capsule.example.com-qpid-router-server-1.0-1.noarch
qpid-cpp-client-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-server-0.30-7.proton.0.9.el6.x86_64
python-qpid-0.30-7.el6.noarch
libqpid-dispatch-0.4-10.el6.x86_64
capsule.example.com-qpid-client-cert-1.0-1.noarch

rpm -qa | grep kombu
python-kombu-3.0.24-8.pulp.el6.noarch

gofer-errors.log gofer-errors.log 14.5 KB logs from capsule Sameer Syed, 03/11/2016 02:38 AM

History

#1 Updated by Eric Helms about 6 years ago

  • Category set to 91
  • Legacy Backlogs Release (now unused) set to 150

#2 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 150 to 144

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (144)

#4 Updated by Justin Sherrill almost 6 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) set to 166

This should be resolved in Katello 3.0 as we are not using goferd anymore for syncing. Closing this, feel free to open a new bug if you are still having issues (since goferd is no longer in the process).

Also available in: Atom PDF