Project

General

Profile

Bug #14163

Routing errors due to missing .css files on navigating sync status page

Added by Walden Raines about 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1315610
Description of problem:
On navigating 'sync status' page, couple of routing error being raised under production.log and firebug raises 404 for missing .css files.

2016-03-08 03:41:03 [app] [I] Started GET "/assets/katello/jquery-ui-1.8.11.custom.css" for 10.65.193.200 at 2016-03-08 03:41:03 -0500
2016-03-08 03:41:03 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery-ui-1.8.11.custom.css"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'

2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/jquery.loadmask.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery.loadmask.css"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'

2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/jquery.treeTable.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery.treeTable.css"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call'

2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/jquery.jscrollpane.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/katello/jquery.jscrollpane.css"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call' | railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app'

2016-03-08 03:41:04 [app] [I] Started GET "/assets/katello/ui.spinner.css" for 10.65.193.200 at 2016-03-08 03:41:04 -0500
2016-03-08 03:41:04 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/katello/ui.spinner.css"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call'

2016-03-08 03:41:10 [app] [I] Started GET "/assets/katello/input-bg.png" for 10.65.193.200 at 2016-03-08 03:41:10 -0500
2016-03-08 03:41:10 [app] [F] | ActionController::RoutingError (No route matches [GET] "/assets/katello/input-bg.png"): | actionpack (4.1.5) lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call' | actionpack (4.1.5) lib/action_dispatch/middleware/show_exceptions.rb:30:in `call' | railties (4.1.5) lib/rails/rack/logger.rb:38:in `call_app' | railties (4.1.5) lib/rails/rack/logger.rb:22:in `call'

Version-Release number of selected component (if applicable):
sat6.2 snap2

How reproducible:
always

Steps to Reproduce:
1. navigate sync status page
2.
3.

Actual results:
ActionController::RoutingError (No route matches [GET] "/assets/katello/ui.spinner.css"):

RoutingError (No route matches [GET] "/assets/katello/input-bg.png"):

RoutingError (No route matches [GET] "/assets/katello/jquery.jscrollpane.css"):

Expected results:
UI shouldn't raise routing errors on navigating sync status page

Additional info:


Related issues

Blocked by Foreman - Bug #14221: Plugin asset compilation does not expand SCSS imports of CSS filesClosed2016-03-15

Associated revisions

Revision e9b932c6 (diff)
Added by Eric Helms about 4 years ago

Fixes #14163: Reference real CSS path for production assets

Revision 249857fd
Added by Eric Helms about 4 years ago

Merge pull request #5887 from ehelms/fixes-14163

Fixes #14163: Reference real CSS path for production assets

Revision f8fbc921 (diff)
Added by Walden Raines almost 4 years ago

Fixes #14163: namespace image urls and use image-url helper.

We were getting 404s for images in production mode because we were not
using the correct paths to images and also not using the image-url
helper. This commit fixes these issues.

http://projects.theforeman.org/issues/14163

Revision 757dcedb
Added by Walden Raines almost 4 years ago

Merge pull request #6131 from waldenraines/14163

Fixes #14163: namespace image urls and use image-url helper.

History

#1 Updated by Eric Helms about 4 years ago

  • Legacy Backlogs Release (now unused) set to 86

#2 Updated by Walden Raines about 4 years ago

  • Assignee changed from Walden Raines to Eric Helms

#3 Updated by Eric Helms about 4 years ago

  • Blocked by Bug #14221: Plugin asset compilation does not expand SCSS imports of CSS files added

#4 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5887 added

#5 Updated by Eric Helms about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Walden Raines almost 4 years ago

  • Status changed from Closed to Assigned
  • Assignee changed from Eric Helms to Walden Raines

#7 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/6131 added

#8 Updated by Eric Helms almost 4 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 144

#9 Updated by Walden Raines almost 4 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF