Project

General

Profile

Bug #14166

empty facet attributes not handled - "Creating a 'new host' fails for lifecycle_env and content_view saying "can't be blank"

Added by Partha Aji almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Host creation
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1313431
Description of problem:

Creating a 'new host' fails for lifecycle_env and content_view saying "can't be blank", even though these values were set.

Version-Release number of selected component (if applicable):
Sat6.2.0-Beta-SNAP1

How reproducible:

Steps to Reproduce:
1. Create a "new host"
2. Provide "life-cycle env" and "content-view" values and also all the other needed values.
3. Click submit button.

Actual results:
To get a message "can't be blank" for "lifecycle-env" and "content-view".

Expected results:
"New host" page submission should be successful.
Additional info:

workaround: Again provide the values of "lifecycle-env" and "content-view".

Associated revisions

Revision 5d64eef2 (diff)
Added by Partha Aji almost 4 years ago

Fixes #14166 - Host facet attributes handling updated

Basically added code to include handling of host facets in hosts where
no form attributes belonging to that facet are set.

Revision c6b76367 (diff)
Added by Partha Aji almost 4 years ago

Fixes #14166 - Host facet attributes handling updated

Basically added code to include handling of host facets in hosts where
no form attributes belonging to that facet are set.

(cherry picked from commit 5d64eef2cba8e56ad39510c3bd1d724bd52762eb)

History

#1 Updated by Partha Aji almost 4 years ago

  • Project changed from Katello to Foreman
  • Category deleted (Hosts)

#2 Updated by Partha Aji almost 4 years ago

  • Subject changed from Creating a 'new host' fails for lifecycle_env and content_view saying "can't be blank" to empty facet attributes not handled - "Creating a 'new host' fails for lifecycle_env and content_view saying "can't be blank"

The title is more of a symptom, but the root cause for this bug is this line in the upstream foreman.
https://github.com/theforeman/foreman/blob/develop/app/models/concerns/facets/managed_host_extensions.rb#L39

     def register_facet_relation(klass, facet_config)
        klass.class_eval do
          has_one facet_config.name, :class_name => facet_config.model.name, :foreign_key => :host_id, :inverse_of => :host
          accepts_nested_attributes_for facet_config.name, :update_only => true
          ...

Basically accepts_nested_attributes_for usage does not provide an easy way to include in a form without sending blank attributes

#3 Updated by The Foreman Bot almost 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3309 added

#4 Updated by Partha Aji almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal almost 4 years ago

  • Category set to Host creation
  • Legacy Backlogs Release (now unused) set to 141

#6 Updated by Dominic Cleal almost 4 years ago

  • Has duplicate Bug #14696: Unable to create new host added

#7 Updated by Dominic Cleal almost 4 years ago

  • Has duplicate deleted (Bug #14696: Unable to create new host)

#8 Updated by Dominic Cleal almost 4 years ago

  • Related to Bug #14696: Unable to create new host added

#9 Updated by Michael Moll over 3 years ago

  • Related to deleted (Bug #14696: Unable to create new host)

Also available in: Atom PDF