Project

General

Profile

Bug #14168

Try to upgrade katello 2.4 with nightly Katello 3.0 and is failed

Added by Mario Gamboa over 3 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
easy
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The installation fail in the upgrade of pulp

[ERROR 2016-03-12 14:44:50 verbose] Attempting to connect to localhost:27017
Attempting to connect to localhost:27017
Write concern for Mongo connection: {}
Loading content types.
Loading type descriptors []
Parsing type descriptors
Validating type descriptor syntactic integrity
Validating type descriptor semantic integrity
Updating the database with types []
Found the following type definitions that were not present in the update collection [puppet_module, erratum, srpm, package_group, package_category, iso, package_environment, drpm, distribution, rpm, yum_repo_metadata_file, docker_image]
Content types loaded.
Ensuring the admin role and user are in place.
Admin role and user are in place.
Beginning database migrations.
/usr/lib/python2.7/site-packages/mongoengine/document.py:324: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
object_id = collection.save(doc, **write_concern)

Applying pulp.server.db.migrations version 13
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0013_role_schema_change.py:16: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
collection.save(role)

/usr/lib/python2.7/site-packages/mongoengine/document.py:367: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
upsert=upsert, **write_concern)

Migration to pulp.server.db.migrations version 13 complete.
Applying pulp.server.db.migrations version 14
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0014_pulp_user_metadata.py:25: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead. {'$set': {constants.PULP_USER_METADATA_FIELDNAME: {}}}, multi=True)

Migration to pulp.server.db.migrations version 14 complete.
Applying pulp.server.db.migrations version 15
Loading type descriptors []
Parsing type descriptors
Validating type descriptor syntactic integrity
Validating type descriptor semantic integrity
Updating the database with types []
Found the following type definitions that were not present in the update collection [puppet_module, erratum, srpm, package_group, package_category, iso, package_environment, drpm, distribution, rpm, yum_repo_metadata_file, docker_image]
Migration to pulp.server.db.migrations version 15 complete.
Applying pulp.server.db.migrations version 16
Creating index to assist with removal of duplicates
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0016_remove_repo_content_unit_owner_type_and_id.py:54: DeprecationWarning: ensure_index is deprecated. Use create_index instead.
collection.ensure_index([(i, -1) for i in index])

Removing duplicate repo_content_units
Removing unused fields (owner_type, owner_id) from repo_content_units
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0016_remove_repo_content_unit_owner_type_and_id.py:34: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {'$unset': {'owner_type': "", 'owner_id': ''}}, multi=True)

Dropping the uniqueness index that included the owner_type & owner_id
Migration to pulp.server.db.migrations version 16 complete.
Applying pulp.server.db.migrations version 17
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0017_distributor_last_published.py:17: DeprecationWarning: save is deprecated. Use insert_one or replace_one instead
collection.save(distributor)

Migration to pulp.server.db.migrations version 17 complete.
Applying pulp.server.db.migrations version 18
Deleted the archived_calls collection.
Migration to pulp.server.db.migrations version 18 complete.
Applying pulp.server.db.migrations version 19
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0019_repo_collection_id.py:18: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "repo_id"}})

Migration to pulp.server.db.migrations version 19 complete.
Applying pulp.server.db.migrations version 20
Migration to pulp.server.db.migrations version 20 complete.
Applying pulp.server.db.migrations version 21
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0021_remove_extra_importer_fields.py:18: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$unset": {"id": True}}, multi=True)

/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0021_remove_extra_importer_fields.py:20: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$unset": {"scheduled_syncs": ""}}, multi=True)

Migration to pulp.server.db.migrations version 21 complete.
Applying pulp.server.db.migrations version 22
/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0022_distributor_collection_trim.py:19: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "distributor_id"}}, multi=True)

/usr/lib/python2.7/site-packages/pulp/server/db/migrations/0022_distributor_collection_trim.py:20: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$unset": {"scheduled_publishes": ""}}, multi=True)

Migration to pulp.server.db.migrations version 22 complete.
Applying pulp_docker.plugins.migrations version 1
Migration to pulp_docker.plugins.migrations version 1 complete.
Applying pulp_puppet.plugins.migrations version 3
Migration to pulp_puppet.plugins.migrations version 3 complete.
Applying pulp_rpm.plugins.migrations version 22
/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0022_rename_unit_id_fields.py:31: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "distribution_id"}}, multi=True)

/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0022_rename_unit_id_fields.py:35: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "errata_id"}}, multi=True)

/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0022_rename_unit_id_fields.py:36: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"from": "errata_from"}}, multi=True)

/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0022_rename_unit_id_fields.py:41: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "package_group_id"}}, multi=True)

/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0022_rename_unit_id_fields.py:46: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "package_category_id"}}, multi=True)

/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0022_rename_unit_id_fields.py:51: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({}, {"$rename": {"id": "package_environment_id"}}, multi=True)

Migration to pulp_rpm.plugins.migrations version 22 complete.
Applying pulp_rpm.plugins.migrations version 23
/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0023_fix_translated_fields_type.py:19: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
collection.update({"translated_name": ""}, {'$set': {'translated_name': {}}}, multi=True)

/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0023_fix_translated_fields_type.py:23: DeprecationWarning: update is deprecated. Use replace_one, update_one or update_many instead.
multi=True

Migration to pulp_rpm.plugins.migrations version 23 complete.
Applying pulp_rpm.plugins.migrations version 24
Migration to pulp_rpm.plugins.migrations version 24 complete.
Applying pulp_rpm.plugins.migrations version 25
Applying migration pulp_rpm.plugins.migrations.0025_export_relative_url failed.

Halting migrations due to a migration failure.
'repo_id'
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 193, in main
return _auto_manage_db(options)
File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 256, in _auto_manage_db
migrate_database(options)
File "/usr/lib/python2.7/site-packages/pulp/server/db/manage.py", line 124, in migrate_database
update_current_version=not options.test)
File "/usr/lib/python2.7/site-packages/pulp/server/db/migrate/models.py", line 186, in apply_migration
migration.migrate()
File "/usr/lib/python2.7/site-packages/pulp_rpm/plugins/migrations/0025_export_relative_url.py", line 60, in migrate
distributors = list(repo_distributors.find({'repo_id': repo_object['repo_id']}))
KeyError: 'repo_id'

Upgrade step migrate_pulp failed. Check logs for more information.
[ERROR 2016-03-12 14:44:50 verbose] Upgrade step migrate_pulp failed. Check logs for more information.


Related issues

Is duplicate of Katello - Bug #14171: Upgrade from Katello 2.3 or 2.4 to 3.0 nightly failRejected2016-03-13

History

#1 Updated by Mario Gamboa over 3 years ago

Also happen from 2.3 to 3.0

#2 Updated by Mario Gamboa over 3 years ago

sorry for the duplicate can this bug be closed and continue with the bug 4171

thank you

#3 Updated by Eric Helms over 3 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 86 to 114

#4 Updated by Eric Helms over 3 years ago

  • Is duplicate of Bug #14171: Upgrade from Katello 2.3 or 2.4 to 3.0 nightly fail added

#5 Updated by Mario Gamboa over 3 years ago

Still failed now from 2.4 to RC2

--> Finished Dependency Resolution
Error: Package: pulp-nodes-common-2.6.4-1.el7.noarch (@katello-pulp)
Requires: python-pulp-bindings = 2.6.4
Removing: python-pulp-bindings-2.6.4-1.el7.noarch (@katello-pulp)
python-pulp-bindings = 2.6.4-1.el7
Updated By: python-pulp-bindings-2.8.0-1.el7.noarch (katello-pulp)
python-pulp-bindings = 2.8.0-1.el7
Error: Package: pulp-nodes-parent-2.6.4-1.el7.noarch (@katello-pulp)
Requires: pulp-server = 2.6.4
Removing: pulp-server-2.6.4-1.el7.noarch (@katello-pulp)
pulp-server = 2.6.4-1.el7
Updated By: pulp-server-2.8.0-1.el7.noarch (katello-pulp)
pulp-server = 2.8.0-1.el7
Error: Package: pulp-nodes-common-2.6.4-1.el7.noarch (@katello-pulp)
Requires: pulp-server = 2.6.4
Removing: pulp-server-2.6.4-1.el7.noarch (@katello-pulp)
pulp-server = 2.6.4-1.el7
Updated By: pulp-server-2.8.0-1.el7.noarch (katello-pulp)
pulp-server = 2.8.0-1.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

#6 Updated by Mario Gamboa about 3 years ago

Ok after some try now is stop on this

[root@nz2zsat01 ~]# foreman-rake db:migrate --trace
  • Invoke db:migrate (first_time)
  • Invoke environment (first_time)
  • Execute environment
  • Invoke db:load_config (first_time)
  • Execute db:load_config
  • Execute db:migrate
    20160222143432 MoveSystemDescriptionToHost: migrating ====================
    -- add_column(:hosts, :description, :text)
    -> 0.0023s
    rake aborted!
    StandardError: An error has occurred, this and all later migrations canceled:

undefined method `description=' for nil:NilClass/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.1.0/db/migrate/20160222143432_move_system_description_to_host.rb:14:in `block in up'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:52:in `block (2 levels) in find_each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:52:in `each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:52:in `block in find_each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:125:in `find_in_batches'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:51:in `find_each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/querying.rb:9:in `find_each'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.1.0/db/migrate/20160222143432_move_system_description_to_host.rb:13:in `up'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:598:in `exec_migration'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:579:in `block (2 levels) in migrate'
/opt/rh/rh-ruby22/root/usr/share/ruby/benchmark.rb:288:in `measure'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:578:in `block in migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/connection_pool.rb:294:in `with_connection'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:577:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:752:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:992:in `block in execute_migration_in_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:1038:in `block in ddl_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:201:in `block in transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:209:in `within_new_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:201:in `transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/transactions.rb:208:in `transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:1038:in `ddl_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:991:in `execute_migration_in_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:953:in `block in migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:949:in `each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:949:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:807:in `up'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:785:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/railties/databases.rake:34:in `block (2 levels) in <top (required)>'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:240:in `call'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:240:in `block in execute'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:235:in `each'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:235:in `execute'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:179:in `block in invoke_with_call_chain'
/opt/rh/rh-ruby22/root/usr/share/ruby/monitor.rb:211:in `mon_synchronize'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:172:in `invoke_with_call_chain'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:165:in `invoke'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:150:in `invoke_task'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:106:in `block (2 levels) in top_level'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:106:in `each'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:106:in `block in top_level'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:115:in `run_with_threads'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:100:in `top_level'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:78:in `block in run'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:176:in `standard_exception_handling'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:75:in `run'
/opt/rh/rh-ruby22/root/usr/bin/rake:33:in `<main>'
NoMethodError: undefined method `description=' for nil:NilClass
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.1.0/db/migrate/20160222143432_move_system_description_to_host.rb:14:in `block in up'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:52:in `block (2 levels) in find_each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:52:in `each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:52:in `block in find_each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:125:in `find_in_batches'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/relation/batches.rb:51:in `find_each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/querying.rb:9:in `find_each'
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.1.0/db/migrate/20160222143432_move_system_description_to_host.rb:13:in `up'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:598:in `exec_migration'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:579:in `block (2 levels) in migrate'
/opt/rh/rh-ruby22/root/usr/share/ruby/benchmark.rb:288:in `measure'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:578:in `block in migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/connection_pool.rb:294:in `with_connection'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:577:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:752:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:992:in `block in execute_migration_in_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:1038:in `block in ddl_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:201:in `block in transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:209:in `within_new_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/connection_adapters/abstract/database_statements.rb:201:in `transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/transactions.rb:208:in `transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:1038:in `ddl_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:991:in `execute_migration_in_transaction'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:953:in `block in migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:949:in `each'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:949:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:807:in `up'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/migration.rb:785:in `migrate'
/opt/rh/rh-ror41/root/usr/share/gems/gems/activerecord-4.1.5/lib/active_record/railties/databases.rake:34:in `block (2 levels) in <top (required)>'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:240:in `call'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:240:in `block in execute'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:235:in `each'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:235:in `execute'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:179:in `block in invoke_with_call_chain'
/opt/rh/rh-ruby22/root/usr/share/ruby/monitor.rb:211:in `mon_synchronize'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:172:in `invoke_with_call_chain'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/task.rb:165:in `invoke'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:150:in `invoke_task'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:106:in `block (2 levels) in top_level'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:106:in `each'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:106:in `block in top_level'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:115:in `run_with_threads'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:100:in `top_level'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:78:in `block in run'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:176:in `standard_exception_handling'
/opt/rh/rh-ruby22/root/usr/share/gems/gems/rake-10.4.2/lib/rake/application.rb:75:in `run'
/opt/rh/rh-ruby22/root/usr/bin/rake:33:in `<main>'
Tasks: TOP => db:migrate
[root@nz2zsat01 ~]#

Also available in: Atom PDF