Project

General

Profile

Bug #14209

Failed pulp tasks are not resumable.

Added by Justin Sherrill over 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Orchestration
Target version:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Partially introduced in https://github.com/Katello/katello/pull/5567
a user is no longer able to 'resume' a failed pulp task. The task never gets restarted in pulp. The task seems to resume in dynflow, but is never restarted in pulp.

Its not the easiest thing to actually reproduce without introducing an exception in pulp via a code change.

Associated revisions

Revision 86de6397 (diff)
Added by Justin Sherrill over 6 years ago

Fixes #14209 - allow for restarting of pulp tasks on resume

The root cause of this is that this commit:

https://github.com/Katello/katello/pull/5567

made it so that resume_external_action no longer threw an exception. Due
to a recent change in dynflow it is needed to throw an exception in the case of
a non-network error. So this change returns the functionality of checking for
pulp task errors on polling, but overrides poll_external_task_with_rescue to not
treat pulp errors as poll errors.

Revision 4af59d05
Added by Justin Sherrill over 6 years ago

Merge pull request #5884 from jlsherrill/14209

Fixes #14209 - allow for restarting of pulp tasks on resume

History

#1 Updated by Justin Sherrill over 6 years ago

  • Description updated (diff)
  • Legacy Backlogs Release (now unused) changed from 86 to 150

#2 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5884 added

#3 Updated by Justin Sherrill over 6 years ago

  • Bugzilla link set to 1317986

#4 Updated by Justin Sherrill over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by The Foreman Bot about 6 years ago

  • Pull request https://github.com/Katello/katello/pull/6011 added

Also available in: Atom PDF