Project

General

Profile

Bug #14219

js error visiting the associated content hosts for a subscription in UI

Added by Thomas McKay over 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Error: [$parse:syntax] Syntax Error: Token ')' is an unexpected token at column 33 of the expression [ host.facts["dmi::memory::size"]) ] starting at [) ].
http://errors.angularjs.org/1.2.9/$parse/syntax?p0=)&p1=is%20an%20unexpected%20token&p2=33&p3=%20host.facts%5BNaNmi%3A%3Amemory%3A%3Asize%22%5D)%20&p4=)%20
    at http://katello:3000/assets/bastion/angular/angular.self.js?body=1:79:12
    at Parser.throwError (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:9904:11)
    at Parser.parse (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:9855:12)
    at http://katello:3000/assets/bastion/angular/angular.self.js?body=1:10680:37
    at $interpolate (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:8201:27)
    at addTextInterpolateDirective (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:6459:27)
    at collectDirectives (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:5733:11)
    at compileNodes (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:5580:22)
    at compileNodes (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:5596:15)
    at compileNodes (http://katello:3000/assets/bastion/angular/angular.self.js?body=1:5596:15)

To reproduce, attach sub to a host and visit that subs Associations UI page.

History

#1 Updated by Thomas McKay over 6 years ago

  • Bugzilla link set to 1318031

#2 Updated by Thomas McKay about 6 years ago

#3 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 86

#4 Updated by The Foreman Bot about 6 years ago

  • Status changed from New to Ready For Testing
  • Assignee set to Eric Helms
  • Pull request https://github.com/Katello/katello/pull/5978 added

#5 Updated by Brad Buckingham about 6 years ago

  • Status changed from Ready For Testing to Duplicate

Marking this issue as a duplicate of http://projects.theforeman.org/issues/14711 .

#6 Updated by Thomas McKay about 6 years ago

  • Blocks deleted (Bug #12533: Subscriptions Tracker)

Also available in: Atom PDF