Project

General

Profile

Bug #14281

Upgrade from Katello 2.3 to 3.0 Nightly Fail with packages not found

Added by Mario Gamboa over 3 years ago. Updated about 1 year ago.

Status:
Duplicate
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hi Team

I trying to make the upgrade from 2.3 to nightly without success this is the procedure i did

1.- Use the correct repos because in the instructions are pointing wrong
yum update -y https://fedorapeople.org/groups/katello/releases/yum/nightly/katello/el7/x86_64/katello-repos-latest.rpm
yum update -y http://yum.theforeman.org/releases/1.11/el7/x86_64/foreman-release.rpm

2.- This point is no included in the instruction and is going to give a lot of dependencies missing from ruby2.2 and ror
yum -y install foreman-release-scl

3.- yum update -y

This is what i got
--> Finished Dependency Resolution
Error: Package: ruby193-rubygem-strong_parameters-0.2.1-11.el7.noarch (@katello)
Requires: ruby193-ruby-wrapper
Removing: ruby193-ruby-wrapper-0.0.2-6.el7.noarch (@foreman)
ruby193-ruby-wrapper = 0.0.2-6.el7
Obsoleted By: tfm-runtime-2.0-2.el7.x86_64 (foreman)
Not found
Error: Package: ruby193-rubygem-tire-0.6.2-1.el7.noarch (@katello)
Requires: ruby193-rubygem(rest-client) >= 1.6
Removing: ruby193-rubygem-rest-client-1.6.7-2.el7.noarch (@foreman)
ruby193-rubygem(rest-client) = 1.6.7
Obsoleted By: tfm-rubygem-rest-client-1.6.7-4.el7.noarch (foreman)
Not found
Error: Package: ruby193-rubygem-less-2.5.1-2.el7.noarch (@foreman-plugins)
Requires: ruby193-rubygem(commonjs) >= 0.2.7
Removing: ruby193-rubygem-commonjs-0.2.7-1.el7.noarch (@foreman-plugins)
ruby193-rubygem(commonjs) = 0.2.7
Obsoleted By: tfm-rubygem-commonjs-0.2.7-3.el7.noarch (foreman-plugins)
Not found
Error: Package: ruby193-rubygem-hashr-0.0.22-5.el7.noarch (@katello)
Requires: ruby193-ruby-wrapper
Removing: ruby193-ruby-wrapper-0.0.2-6.el7.noarch (@foreman)
ruby193-ruby-wrapper = 0.0.2-6.el7
Obsoleted By: tfm-runtime-2.0-2.el7.x86_64 (foreman)
Not found
Error: Package: ruby193-rubygem-less-2.5.1-2.el7.noarch (@foreman-plugins)
Requires: ruby193-rubygem(commonjs) < 0.3
Removing: ruby193-rubygem-commonjs-0.2.7-1.el7.noarch (@foreman-plugins)
ruby193-rubygem(commonjs) = 0.2.7
Obsoleted By: tfm-rubygem-commonjs-0.2.7-3.el7.noarch (foreman-plugins)
Not found
Error: Package: ruby193-rubygem-tire-0.6.2-1.el7.noarch (@katello)
Requires: ruby193-rubygem(ansi)
Removing: ruby193-rubygem-ansi-1.4.3-3.el7.noarch (@katello)
ruby193-rubygem(ansi) = 1.4.3
Obsoleted By: tfm-rubygem-ansi-1.4.3-6.el7.noarch (foreman)
Not found

4.- if i make the same procedure but just before upgrade to 2.4 works ok the issue is the upgrade procedure from 2.3 to nightly (3.0) is no working as expected

History

#1 Updated by Eric Helms over 3 years ago

  • Status changed from New to Duplicate
  • Legacy Backlogs Release (now unused) changed from 144 to 114

Also available in: Atom PDF