Project

General

Profile

Bug #14287

Upgrade from Katello 2.4 to 3.0 fails at step errata_import

Added by Mike McCune about 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Upgrades
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Error:

  1. foreman-installer --scenario katello --upgrade
    Upgrading...
    Upgrade Step: stop_services...
    Upgrade Step: start_databases...
    Upgrade Step: migrate_pulp...
    Upgrade Step: start_httpd...
    Upgrade Step: migrate_candlepin...
    Upgrade Step: migrate_foreman...
    Upgrade Step: migrate_gutterball...
    Upgrade Step: Running installer...
    Installing Done [100%] [..................................................................]
    The full log is at /var/log/foreman-installer/katello.log
    Upgrade Step: restart_services...
    Upgrade Step: db_seed...
    Upgrade Step: errata_import (this may take a while) ...
    Upgrade step errata_import failed. Check logs for more information.

This upgrade step needs converting to the new Host Unification Facets


Related issues

Is duplicate of Katello - Bug #14241: katello-installer --upgrade does not print error on stdout for an "Importing Errata" errorClosed2016-03-16

History

#1 Updated by Mike McCune about 6 years ago

  • Bugzilla link set to 1314695

#2 Updated by The Foreman Bot about 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5901 added

#3 Updated by Mike McCune about 6 years ago

  • Status changed from Ready For Testing to Duplicate

#4 Updated by Eric Helms about 6 years ago

  • Is duplicate of Bug #14241: katello-installer --upgrade does not print error on stdout for an "Importing Errata" error added

#5 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF