Project

General

Profile

Bug #14372

Content Host shows green status with "Warning"

Added by John Mitsch over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Hosts
Target version:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Description of problem:
The content host status is a green dot, but it shows "Warning"

Version-Release number of selected component (if applicable):

How reproducible:
Easy

Steps to Reproduce:
1. Install a capsule normally
2. Check the content host details - provisioning details tab for that capsule.

Actual results:
In the status field - the dot is green but shows a warning

Expected results:
In the status field the dot should either be yellow and show Warning or Green and show "Fully entitled" (or a similar successful message)

Additional info:
screenshot http://www.clipular.com/c/5666756448747520.png?k=yqroXkU_JomZrASQPepyfKhKElQ


Related issues

Related to Foreman - Bug #14401: Host#refresh_global_status not persisting changes to the dbClosed2016-03-30

Associated revisions

Revision d31dff1e (diff)
Added by John Mitsch over 3 years ago

Fixes #14372 - Content host status is green, but shows warning

Revision 47b1e8bd
Added by John Mitsch over 3 years ago

Merge pull request #5925 from johnpmitsch/content_host_status_14372

Fixes #14372 - Content host status is green, but shows warning

Revision bab5613e (diff)
Added by John Mitsch about 3 years ago

Refs #14372 - global status not updating correctly on host w/ CV (#6166)

When creating a host with a content view and lifecycle environment,
the global status will not be correct as the errata status will be
marked as relevant when it is not, since the host is still not
registered with pulp. This will check for a uuid, which is only
present if the host is registered with pulp.

History

#1 Updated by John Mitsch over 3 years ago

  • Assignee changed from Thomas McKay to John Mitsch

#2 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5925 added

#3 Updated by Marek Hulán over 3 years ago

  • Related to Bug #14401: Host#refresh_global_status not persisting changes to the db added

#4 Updated by John Mitsch over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Eric Helms over 3 years ago

  • Legacy Backlogs Release (now unused) set to 86

#6 Updated by Justin Sherrill over 3 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 143

#7 Updated by The Foreman Bot about 3 years ago

  • Pull request https://github.com/Katello/katello/pull/6166 added

#8 Updated by John Mitsch almost 3 years ago

  • Subject changed from Content Host status is green, but shows "Warning" to Content Host shows green status with "Error"
  • Description updated (diff)

#9 Updated by John Mitsch almost 3 years ago

  • Subject changed from Content Host shows green status with "Error" to Content Host shows green status with "Warning"

#10 Updated by John Mitsch almost 3 years ago

  • Description updated (diff)

Also available in: Atom PDF