Project

General

Profile

Bug #1439

Foreman can only use Puppetmaster's via smartproxy that expose "Puppet CA"

Added by Ashley Penney over 7 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
easy
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Puppetmaster's are only usable from the host edit page if they have the "Puppet CA" feature which breaks in the face of a single puppetmaster dedicated to certs:

diff --git a/app/views/hosts/_form.html.erb b/app/views/hosts/_form.html.erb
index 8a814aa..04fabd6 100644
--- a/app/views/hosts/_form.html.erb
+++ b/app/views/hosts/_form.html.erb
@@ -25,7 +25,7 @@
           :help_inline => image_tag("spinner.gif", :id => "indicator1", :style => "display:none;")
       } %>
       <%= select_f f, :environment_id, Environment.all, :id, :to_label, { :include_blank => true } %>
-      <%= select_f f, :puppetproxy_id,Feature.find_by_name("Puppet CA").smart_proxies, :id, :name,
+      <%= select_f f, :puppetproxy_id,Feature.find_by_name("Puppet").smart_proxies, :id, :name,
         { :include_blank => true},
         { :label => "Puppet Master Proxy"}
       %>


Sorry this took so long to patch, Ohadlevy, but as you know I'm an idiot!

Related issues

Is duplicate of Foreman - Feature #1503: When creating a host, it should be possible to define a Puppet CA and a Puppet Master to useClosed2012-02-23

History

#1 Updated by Ohad Levy over 7 years ago

  • Assignee set to Ashley Penney
  • Target version set to 1.0
  • Difficulty set to easy

mind sending a git patch?

#2 Updated by Ohad Levy over 7 years ago

bump!

and, maybe we should display both? (CA + Puppet) ?

#3 Updated by Ashley Penney over 7 years ago

Sorry, I didn't see the git patch thing. I'll take care of this on Monday. Actually your update made me think - it would be nice to have a separate drop-down for CA. In my environment I have separated out the Puppet and CA bit so being able to select both and then deal with that in templates would be awesome.

As it stands they are all pointing to one CA server right now but it makes sense to keep that information in Foreman rather than just hardcoded into a template within puppet.

#4 Updated by Ohad Levy over 7 years ago

sounds good
btw: today is Thu :)

#6 Updated by Ohad Levy over 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF