Project

General

Profile

Bug #14397

hammer ping prompts for admin password

Added by Andrew Kofink almost 3 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1313441
Description of problem:
issuing `hammer ping` command results in prompting user for admin password and anything submitted for a password is being accepted.
The command then prints the proper ping output

Version-Release number of selected component (if applicable):
6.2.0 Snap1

How reproducible:
always

Steps to Reproduce:
1. `hammer ping`

Actual results:
  1. hammer ping
    Ignoring ruby-libvirt-0.5.2 because its extensions are not built. Try: gem pristine ruby-libvirt --version 0.5.2
    [Foreman] Password for admin: <someTotallyInvalidPassword>
    candlepin:
    Status: ok
    Server Response: Duration: 74ms
    candlepin_auth:
    Status: ok
    Server Response: Duration: 72ms
    pulp:
    Status: ok
    Server Response: Duration: 155ms
    foreman_tasks:
    Status: ok
    Server Response: Duration: 29ms

Expected results:
`hammer ping` should not prompt for credentials.

Additional info:

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/373 added

#2 Updated by Eric Helms almost 3 years ago

  • Project changed from Hammer CLI to Katello
  • Assignee set to Andrew Kofink
  • Legacy Backlogs Release (now unused) set to 143

#3 Updated by Eric Helms almost 3 years ago

  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF