Project

General

Profile

Bug #14401

Host#refresh_global_status not persisting changes to the db

Added by John Mitsch almost 3 years ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Plugins-Engines
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

related to http://projects.theforeman.org/issues/14372

Refreshing the global_status here [1] does not persist changes to the database, which is causing problems in Katello when calling global_status (see above bug).

[1] https://github.com/theforeman/foreman/blob/c7d9169d12e16bcd5f4e3466e5cf99ca963eeea7/app/models/host/managed.rb#L859


Related issues

Related to Katello - Bug #14372: Content Host shows green status with "Warning"Closed2016-03-29
Related to Foreman - Bug #14518: unable to save report due to a host os misconfigurationClosed2016-04-07
Related to Foreman - Bug #14516: Host::Base#domain_id= delegated to primary_interface.domain_id=, but primary_interface is nilClosed2016-04-07
Related to Foreman - Refactor #15849: Improve performance of host global status updatesNew2016-07-27

Associated revisions

Revision b3d3d65d (diff)
Added by John Mitsch almost 3 years ago

Fixes #14401 - Refreshing Host's global status not persisting to the database

History

#1 Updated by The Foreman Bot almost 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3380 added

#2 Updated by Marek Hulán almost 3 years ago

  • Related to Bug #14372: Content Host shows green status with "Warning" added

#3 Updated by Marek Hulán almost 3 years ago

  • Category set to Plugins-Engines

#4 Updated by Marek Hulán almost 3 years ago

  • Legacy Backlogs Release (now unused) set to 152

#5 Updated by John Mitsch almost 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#6 Updated by Dominic Cleal almost 3 years ago

  • Related to Bug #14518: unable to save report due to a host os misconfiguration added

#7 Updated by Dominic Cleal almost 3 years ago

  • Legacy Backlogs Release (now unused) changed from 152 to 136

Bumping due to linked regression, possibly also linked to #14516.

#8 Updated by Dominic Cleal almost 3 years ago

  • Related to Bug #14516: Host::Base#domain_id= delegated to primary_interface.domain_id=, but primary_interface is nil added

#9 Updated by Tomer Brisker over 2 years ago

  • Related to Refactor #15849: Improve performance of host global status updates added

Also available in: Atom PDF