Project

General

Profile

Actions

Bug #14442

closed

"Power on" raises error when entrypoint is not on container's $PATH - uninitialized constant Fog::Errors::Error::NotFound

Added by Daniel Lobato Garcia almost 8 years ago. Updated almost 8 years ago.

Status:
Duplicate
Priority:
Normal
Category:
-
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1323077
Description of problem: I created a container on registered atomic host using 'docker hub'. Container was created successfully. But when I click on 'power on' button, I got following error:

Error: Error - uninitialized constant Fog::Errors::Error::NotFound

No error in production.log:

2016-04-01 04:05:42 [app] [I] Started PUT "/containers/1/power" for 10.65.193.200 at 2016-04-01 04:05:42 -0400
2016-04-01 04:05:43 [app] [I] Processing by ContainersController#power as HTML
2016-04-01 04:05:43 [app] [I] Parameters: {"authenticity_token"=>"PWbuBmdIUUdTJRr9E/nEIW3loH1O6Xf8NGccK3kmsMg=", "id"=>"1"}
2016-04-01 04:05:43 [app] [D] Setting current user thread-local variable to admin
2016-04-01 04:05:43 [app] [D] Setting current organization thread-local variable to Default Organization
2016-04-01 04:05:43 [app] [D] Setting current location thread-local variable to none
2016-04-01 04:05:43 [app] [I] Redirected to https://cloud-qe-15.idmqe.lab.eng.bos.redhat.com/containers/1
2016-04-01 04:05:43 [app] [I] Completed 302 Found in 382ms (ActiveRecord: 12.9ms)

Version-Release number of selected component (if applicable):
sat6.2 beta snap6

How reproducible:
always

Steps to Reproduce:
1. create a container on atomic host
2. Power on the container
3.

Actual results:
Error: Error - uninitialized constant Fog::Errors::Error::NotFound

Expected results:
on clicking 'Power ON" container should be up and running and no error should be raised.

Additional info:


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Refactor #14368: Update fog to 1.38.0ClosedDominic Cleal03/29/2016Actions
Actions #1

Updated by Daniel Lobato Garcia almost 8 years ago

Apparently it only fails when the container entrypoint is wrong.
There's something rescuing the wrong constant, not in Foreman or ForemanDocker though (Fog::Errors::Error::NotFound).
I'll fix it to rescue the actual problem and display the error.

Actions #2

Updated by Daniel Lobato Garcia almost 8 years ago

Fixed on fog - https://github.com/fog/fog/commit/9ac62416512501d30ebcf9a1c49dadec1f0cc7cc - so we don't really have to do anything here since core uses 1.38 which fixes this.

Actions #3

Updated by Daniel Lobato Garcia almost 8 years ago

  • Bugzilla link deleted (1323077)
Actions #4

Updated by Daniel Lobato Garcia almost 8 years ago

Actions #5

Updated by Daniel Lobato Garcia almost 8 years ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF