Project

General

Profile

Bug #14470

Command line arguments not working

Added by Jason Hane about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Installer
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I've tested these command line arguments so far and they don't seem to do anything in Foreman 1.10.3 (Katello 2.4).

--no-enable-foreman-plugin-bootdisk (installs the plugin anyway)
--foreman-admin-email (set to the default)

History

#1 Updated by Jason Hane about 6 years ago

Also when specifying --certs-ssl-build-dir the only thing that goes in there is a broken symlink. The rest of the certificates still go to /root/ssl-build. I've also noticed this directory is hardcoded in some Katello scripts (katello-remove).

#2 Updated by Marek Hulán about 6 years ago

  • Status changed from New to Need more information

which installer do you use? foreman-installer or katello-installer? was it clean machine? what foreman/katello packages did you install before you ran the installer for the first time?

#3 Updated by Jason Hane about 6 years ago

This was the katello-installer on a clean VM running RHEL 7.2. Here are the steps I took to install it.

yum -y install git ruby
yum -y  --disablerepo="*" --enablerepo=rhel-7-server-rpms install yum-utils wget
yum-config-manager --disable "*" 
yum-config-manager --enable rhel-7-server-rpms
yum-config-manager --enable rhel-7-server-optional-rpms
yum-config-manager --enable rhel-7-server-extras-rpms
yum -y localinstall http://fedorapeople.org/groups/katello/releases/yum/2.4/katello/RHEL/7Server/x86_64/katello-repos-latest.rpm
yum -y localinstall http://yum.theforeman.org/releases/1.10/el7/x86_64/foreman-release.rpm
yum -y localinstall http://yum.puppetlabs.com/puppetlabs-release-el-7.noarch.rpm
# For some reason this is necessary to detect foreman-release-scl
yum clean all
yum -y install foreman-release-scl

yum -y install katello

katello-installer \
--no-enable-foreman-plugin-bootdisk \
--no-enable-foreman-plugin-discovery \
--capsule-puppet false \
--capsule-puppetca false \
--foreman-admin-email me@example.com \
--foreman-admin-username admin \
--foreman-admin-password blahblah \
--foreman-db-username foreman \
--foreman-db-password dbblahblah \
--foreman-db-pool 10 \
--foreman-initial-location "Right Here" \
--foreman-initial-organization Org \
--foreman-oauth-consumer-key consumerkey \
--foreman-oauth-consumer-secret consumersecret \
--foreman-passenger-min-instances 5 \
--katello-num-pulp-workers 10 \
--katello-oauth-secret oauthsecret \
--katello-post-sync-token synctoken \
--certs-city "My City" \
--certs-country US \
--certs-state Pennsylvania \
--certs-org-unit TechOps

#4 Updated by Dominic Cleal about 6 years ago

  • Project changed from Foreman to Katello
  • Category set to Installer
  • Status changed from Need more information to New

Perhaps a package has a hard dependency on the plugin causing it to be installed, so changing project.

I can't reproduce the issue with the e-mail address in Foreman, perhaps the database was already seeded by an earlier installer run, or by some other process interfering.

# foreman-installer --foreman-admin-email me@example.com
# hammer user info --login=admin
Id:                   3
Login:                admin
Name:                 Admin User
Email:                me@example.com

#5 Updated by Eric Helms about 6 years ago

  • Status changed from New to Need more information
  • Legacy Backlogs Release (now unused) set to 143

In 2.4, the katello RPM required more plugins than the application required, in other words it was installing a set of plugins that weren't necessarily used or needed. In 3.0 we changed this to require only what is necessary and that is why the --no-enable still shows it as installed.

The email issue I can't explain as we aren't doing anything related to that parameter.

The ability to specify the ssl build directory should probably be removed and is a valid bug if you would like to open one separately or change this bug to be specific to that.

#6 Updated by Jason Hane about 6 years ago

For the --foreman-admin-email flag, is that supposed to update the "Administrator email address" in Settings? If so, on our installation it's not doing that.

#7 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (143)

#8 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

#9 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Need more information to Rejected

Also available in: Atom PDF