Project

General

Profile

Bug #14484

Unable to select various tabs under puppetca tab of smart-proxy

Added by Walden Raines about 6 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1319278
Description of problem:

On the smart-proxy show page, we have the "Puppet CA" Tab, which in-turn has these below tabs.

a) General
b) Certificates
c) Autosign entries

The above tabs do not get loaded currently upon clicking them.

I see the below error in the browser:

Error: [$injector:unpr] Unknown provider: eProvider <- e
http://errors.angularjs.org/1.2.9/$injector/unpr?p0=eProvider%20%3C-%20e
r/<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:14773
Ot/$.$injector<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:30308
n@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29573
Ot/x.$injector<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:30401
n@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29573
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:1:29858
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:4:32730
m/this.when/s.matcher/<@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:5:511
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:5:1054
r@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:5:1167
kn/this.$get</c.prototype.$broadcast@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:3185
l@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:2:23783
fn/this.$getkn/this.$get</c.prototype.$eval@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:1954
kn/this.$get</c.prototype.$digest@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:654
kn/this.$get</c.prototype.$apply@https://abc.redhat.com/assets/bastion/bastion-da63d18ea32fb7ba02e57c8c5bdc22689a2bee4cbf23b20f7cd975577b8bee6f.js:3:2275
fn/this.$getit.event.dispatch@https://abc.redhat.com/assets/application-9e1b8cb558d4244d3c0ba8e714ce09141fae0a7417e5c7c02a4adeb3014b4078.js:26:1060
it.event.add/g.handle@https://abc.redhat.com/assets/application-9e1b8cb558d4244d3c0ba8e714ce09141fae0a7417e5c7c02a4adeb3014b4078.js:25:30738

This issue is also seen in latest stable chrome version : 48.0.2564.116 (64-bit)

Version-Release number of selected component (if applicable):
SNAP4-compose1

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:
the page doesn't load upon selection

Expected results:
the page should load upon selection

Additional info:


Related issues

Related to Foreman - Bug #14679: smart proxy puppet CA sub-tabs missing data-toggle="tab"Closed2016-04-17
Is duplicate of Katello - Bug #13718: Unable to select various tabs under puppetca tab of smart-proxyClosed2016-02-15

Associated revisions

Revision 78492d28 (diff)
Added by Walden Raines about 6 years ago

Fixes #14484: use minification safe format to prevent JS error.

The parameters to $urlRouterProvider.when() are injected when the
function form is used so we need to use the minification safe format.

http://projects.theforeman.org/issues/14484

Revision 3991abfa
Added by Walden Raines about 6 years ago

Merge pull request #5938 from waldenraines/14484

Fixes #14484: use minification safe format to prevent JS error.

History

#1 Updated by The Foreman Bot about 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5938 added

#2 Updated by Walden Raines about 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 86

#4 Updated by Walden Raines about 6 years ago

  • Project changed from Katello to Foreman
  • Category changed from Web UI to Web Interface
  • Status changed from Closed to New
  • Assignee deleted (Walden Raines)

#5 Updated by Dominic Cleal about 6 years ago

  • Project changed from Foreman to Katello
  • Category deleted (Web Interface)

Why was this assigned to Foreman? It has a Katello PR, release and commits attached. Putting it back.

#6 Updated by Tomer Brisker about 6 years ago

  • Has duplicate Bug #13718: Unable to select various tabs under puppetca tab of smart-proxy added

#7 Updated by Tomer Brisker about 6 years ago

This is caused by a bug in angular: https://github.com/angular/angular.js/issues/1647

#8 Updated by Tomer Brisker about 6 years ago

  • Related to Bug #14679: smart proxy puppet CA sub-tabs missing data-toggle="tab" added

#9 Updated by Walden Raines about 6 years ago

  • Status changed from New to Duplicate
  • Bugzilla link deleted (1319278)

Duplicate of #13718

#10 Updated by Walden Raines about 6 years ago

  • Has duplicate deleted (Bug #13718: Unable to select various tabs under puppetca tab of smart-proxy)

#11 Updated by Walden Raines about 6 years ago

  • Is duplicate of Bug #13718: Unable to select various tabs under puppetca tab of smart-proxy added

Also available in: Atom PDF