Project

General

Profile

Bug #1453

Solaris install fails if Safemode-rendering is enabled

Added by David M. over 7 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Templates
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

The installation of solaris using foreman fails if "safemode_render" is true.

This message is shown when trying to open the template:

There was an error rendering the Jumpstart Default template: undefined method 'use_image' for Host::Jail (Host)

Workaround: Set "safemode_render" to false in "More->Settings".


Related issues

Related to Foreman - Refactor #11293: Add tests for methods functionality defined in HostTemplateHelpersNew2015-08-05

Associated revisions

Revision a24c693c (diff)
Added by Marek Hulán about 4 years ago

Refs #1453 - use host jumpstart helpers

Revision 6ea461fe (diff)
Added by Marek Hulán about 4 years ago

Fixes #1453 - add use_image and jumpstart helpers to Host jail

Revision 535547e6
Added by Dominic Cleal about 4 years ago

Merge pull request #193 from ares/refs/1453

Refs #1453 - use host jumpstart helpers

History

#1 Updated by David M. over 7 years ago

There is also an error when viewing the pxegrub-template. This time the workaround doesnt help:

There was an error rendering the Jumpstart default PXEGrub template: undefined local variable or method `multiboot' for #<#<Class:0x7ffa030e0038>:0x7ffa02a55f60>

#2 Updated by Garrett D over 5 years ago

I am experiencing this with foreman-1.4.2-1.el6.noarch on CentOS 6.5.

There was an error rendering the Jumpstart default PXEGrub template: undefined local variable or method `multiboot' for #<#<Class:0x007f147cdbf258>:0x007f147cda92f0>

#3 Updated by Marek Hulán about 4 years ago

  • Description updated (diff)
  • Category changed from Web Interface to Templates
  • Assignee changed from Ohad Levy to Marek Hulán

This was caused by https://github.com/theforeman/community-templates/blob/develop/jumpstart/provision.erb#L8

For multiboot (and other) we need to allow several methods in host jail and change the template to load it from @host, since it's defined in HostTemplateHelpers concern, which is not included in controller.

#4 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2525 added
  • Pull request deleted ()

#5 Updated by Marek Hulán about 4 years ago

Community templates related PR opened at https://github.com/theforeman/community-templates/pull/193

#6 Updated by Marek Hulán about 4 years ago

  • Related to Refactor #11293: Add tests for methods functionality defined in HostTemplateHelpers added

#7 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 63

#8 Updated by Marek Hulán about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF