Project

General

Profile

Bug #14580

SSL Error on capsule install

Added by Cameron Berkley about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

I was installing capsule per the instructions at http://www.katello.org/docs//installation/capsule.html , and saw I needed the repositories described on http://www.katello.org/docs//installation/index.html#required-repositories .
The listed URLs are invalid, it appears the version number is missing.

I went ahead and added the 3.0 repos, but when I try to yum install foreman-installer-katello, various packages 404.

I see the following:
@Downloading packages:
foreman-installer-1.10.3-1.el7 FAILED
http://yum.theforeman.org/nightly/el7/x86_64/foreman-installer-1.10.3-1.el7.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/

foreman-debug-1.10.3-1.el7.noa FAILED
http://yum.theforeman.org/nightly/el7/x86_64/foreman-debug-1.10.3-1.el7.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
foreman-proxy-1.10.3-1.el7.noa FAILED
http://yum.theforeman.org/nightly/el7/x86_64/foreman-proxy-1.10.3-1.el7.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
foreman-selinux-1.10.3-1.el7.n FAILED
http://yum.theforeman.org/nightly/el7/x86_64/foreman-selinux-1.10.3-1.el7.noarch.rpm: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
foreman-installer-katello-3.1. FAILED
https://fedorapeople.org/groups/katello/releases/yum/2.4/katello/RHEL/7/x86_64/foreman-installer-katello-3.1.0-1.nightly.201603210055git730ba84.el7.noarch.rpm: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
katello-installer-base-3.1.0-1 FAILED
https://fedorapeople.org/groups/katello/releases/yum/2.4/katello/RHEL/7/x86_64/katello-installer-base-3.1.0-1.nightly.201603210055git730ba84.el7.noarch.rpm: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
(1/9): katello-certs-tools-2.4.0-1.el7.noarch.rpm | 76 kB 00:00:00
katello-selinux-3.0.1-1.el7.no FAILED
https://fedorapeople.org/groups/katello/releases/yum/2.4/katello/RHEL/7/x86_64/katello-selinux-3.0.1-1.el7.noarch.rpm: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
katello-service-3.1.0-2.nightl FAILED
https://fedorapeople.org/groups/katello/releases/yum/2.4/katello/RHEL/7/x86_64/katello-service-3.1.0-2.nightly.el7.noarch.rpm: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.

Error downloading packages:
foreman-installer-katello-3.1.0-1.nightly.201603210055git730ba84.el7.noarch: [Errno 256] No more mirrors to try.
katello-service-3.1.0-2.nightly.el7.noarch: [Errno 256] No more mirrors to try.
katello-selinux-3.0.1-1.el7.noarch: [Errno 256] No more mirrors to try.
1:foreman-installer-1.10.3-1.el7.noarch: [Errno 256] No more mirrors to try.
foreman-proxy-1.10.3-1.el7.noarch: [Errno 256] No more mirrors to try.
foreman-debug-1.10.3-1.el7.noarch: [Errno 256] No more mirrors to try.
katello-installer-base-3.1.0-1.nightly.201603210055git730ba84.el7.noarch: [Errno 256] No more mirrors to try.
foreman-selinux-1.10.3-1.el7.noarch: [Errno 256] No more mirrors to try.
@

History

#1 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 86

Cameron,

The output looks like you are using a combination of Katello 2.4, Katello 3.0 and Katello nightly repositories which is causing mismatches with the required Foreman versions as well. The docs you linked are for the nightly version of Katello. You may want to use the 3.0 RC2 (http://www.katello.org/docs/3.0/installation/index.html). Please let me know if that resolves the issue so we can close this.

#2 Updated by Cameron Berkley about 6 years ago

Eric, thank you for noticing that. Since our main Katello server runs 2.4 I tried again with the 2.4 repos. Unfortunately I now seem to be getting an SSL error when I try to install the capsule. The capsule-installer reports:

Proxy dns3-vm.sc.fsu.edu cannot be registered (422 Unprocessable Entity): Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verif...) for proxy https://dns3-vm.sc.fsu.edu:9090/features Please check the proxy is configured and running on the host.
/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[dns3-vm.sc.fsu.edu]/ensure: change from absent to present failed: Proxy dns3-vm.sc.fsu.edu cannot be registered (422 Unprocessable Entity): Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verif...) for proxy https://dns3-vm.sc.fsu.edu:9090/features Please check the proxy is configured and running on the host.

I have confirmed that foreman-proxy is running, and navigating to https://dns3-vm.sc.fsu.edu/features shows the features.

Here is a link to my debug file:
http://debugs.theforeman.org/foreman-debug-AydUK.tar.xz

#3 Updated by Cameron Berkley about 6 years ago

It's worth noting that I first attempted to re-install capsule with a new katello master and got this error, but got the same error when attempting to install it on a new server as well.

#4 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) changed from 86 to 150

#5 Updated by Justin Sherrill almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 150 to 144

#6 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#7 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) changed from 168 to 171

#8 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) deleted (171)

#9 Updated by Justin Sherrill almost 6 years ago

  • Subject changed from Various packages seem to not exist to SSL Error on capsule install
  • Status changed from New to Need more information

Are you still experiencing this problem?

#10 Updated by Justin Sherrill almost 6 years ago

  • Status changed from Need more information to Rejected
  • Legacy Backlogs Release (now unused) set to 166

Just saw http://projects.theforeman.org/issues/14805

Closing this issue as the package install issues seem to be resolved

Also available in: Atom PDF