Project

General

Profile

Bug #14602

Select Puppet::server_implementation from installer

Added by Matthias Thubauville over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Category:
Installer
Target version:
Difficulty:
trivial
Triaged:
Yes
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

In some environments it might be preferred to use the JVM Puppetserver instead of the Puppet Master Passenger.

The theforeman/puppet-puppet module has this feature already included.

Therefore the katello/puppet-capsule module only needs to pass the parameter to the ::puppet class.

(Hopefully I will submit a patch to the katello/puppet-capsule module soon. Im currently performing some local tests.)

History

#1 Updated by Eric Helms about 3 years ago

  • Assignee set to Matthias Thubauville
  • Legacy Backlogs Release (now unused) set to 144

#2 Updated by Matthias Thubauville about 3 years ago

Somehow the pull request was not add here automatically - did I miss something?

Just in case - here is the URL: https://github.com/Katello/puppet-capsule/pull/82

#3 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 144 to 168

#4 Updated by Eric Helms about 3 years ago

  • Legacy Backlogs Release (now unused) changed from 168 to 162

#5 Updated by Justin Sherrill almost 3 years ago

  • Status changed from New to Closed
  • Pull request https://github.com/Katello/puppet-capsule/pull/90 added

Also available in: Atom PDF