Project

General

Profile

Feature #14633

Support for Kerberos Authentication

Added by Sameer Syed about 3 years ago. Updated about 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Are there any plans to add support for Kerberos user authentication apart from the LDAP authentication that is already there?


Related issues

Is duplicate of Hammer CLI - Feature #8923: Ability to use Negotiate/Kerberos authentication to API and hammerNew2015-01-13

History

#1 Updated by Dominic Cleal about 3 years ago

  • Is duplicate of Feature #8923: Ability to use Negotiate/Kerberos authentication to API and hammer added

#2 Updated by Dominic Cleal about 3 years ago

  • Status changed from New to Duplicate

Thanks for the report, this is already filed as ticket #8923.

#3 Updated by Sameer Syed about 3 years ago

I am not sure why this ended up in hammer project. What I meant was support for Kerberos user authentication for WebUI, similar to LDAP authentication available in WebUI.

#4 Updated by Dominic Cleal about 3 years ago

This is available already, see http://theforeman.org/manuals/1.11/index.html#5.7ExternalAuthentication, particularly section 5.7.3. It's written for FreeIPA, but should be largely applicable to other services.

Also available in: Atom PDF