Project

General

Profile

Bug #14636

Unable to search puppet classes with long names

Added by Luke Simmons about 4 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

It's a common feature to have a rather sprawling profile class in Puppet. The Puppet class names are truncated in Foreman for visibility in the web interface. This is fine IMHO. The tooltip displays the long name, but you cannot filter the results by the actual class name. The only thing getting filtered is the HTML display name.

For example, I can find profile::foo::bar::pants by searching profile, foo, bar or pants, but I cannot search for profile::foo::bar::authorisation::pants. Pants in the last example will not filter. The JavaScript in the filter is entirely HTML based searching only the display names. Shouldn't this be a direct ajax SQL call in the filter? Or at least configurable?


Related issues

Related to Foreman - Bug #5733: Puppet class names get shortenedResolved2014-05-15
Has duplicate Foreman - Bug #2956: Autocompletion failure when adding class to hostDuplicate2013-08-22

Associated revisions

Revision 0aacf330 (diff)
Added by Tomer Brisker about 4 years ago

Fixes #14636 - correctly search puppet class on host form

Searching for puppet classes that were ellipsized did not work as
expected on the host edit form. This was due to the search looking only
in the span content which was truncated and did not contain the entire
puppet class name. Also, cleaned up the js code to be clearer and more
efficiant.

Revision 01d4f092 (diff)
Added by Tomer Brisker about 4 years ago

Fixes #14636 - correctly search puppet class on host form

Searching for puppet classes that were ellipsized did not work as
expected on the host edit form. This was due to the search looking only
in the span content which was truncated and did not contain the entire
puppet class name. Also, cleaned up the js code to be clearer and more
efficiant.

(cherry picked from commit 0aacf3304d8d36fcd4d593036bdc64d02cc3112b)

History

#1 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #5733: Puppet class names get shortened added

#2 Updated by Tomer Brisker about 4 years ago

Hello,
I could not manage to reproduce this.
Searching for a class with a very long name that is truncated works just fine for me - see attached screenshot.
Please provide more information on how to reproduce this.

#3 Updated by Dominic Cleal about 4 years ago

  • Status changed from Need more information to New

Tomer, my reading is that this is the inline search box on the host edit page, Puppet Classes tab, under Available Classes. I can confirm the bug report.

#4 Updated by Tomer Brisker about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Tomer Brisker

Thanks for the clarification Dominic. I found the cause of this bug.

#5 Updated by The Foreman Bot about 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/3428 added

#6 Updated by Anonymous about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#7 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 141

#8 Updated by Tomer Brisker almost 3 years ago

  • Has duplicate Bug #2956: Autocompletion failure when adding class to host added

Also available in: Atom PDF