Project

General

Profile

Feature #1464

Parameters in subnets

Added by Olivier Le Cam over 8 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I would like to have the possibility to affect Parameters in the Subnets UI, the same way it is possible with Domains.
My main use case is to define a "datacenter" parameter associated with each Subnets.


Related issues

Related to Foreman - Feature #4127: Array, Boolean and other types support in "hostgroup parameters"Closed
Related to Foreman - Bug #5204: support class parameters at the domain and OS levels.New2014-04-15
Is duplicate of Foreman - Feature #3582: Allow Subnets to have Parameters like DomainsClosed2013-11-05

History

#1 Updated by Ohad Levy over 8 years ago

Hmm... would a DC level make more sense?

additionally, you can do that today using the smart variables.

#2 Updated by Ohad Levy over 8 years ago

  • Status changed from New to Feedback

#3 Updated by Olivier Le Cam over 8 years ago

Hi -

Sorry for the delay, I was looking for a few time in order for me to give smart variables a try (never used them before).

Ohad Levy wrote:

Hmm... would a DC level make more sense?

Do you mean having an additional DC (or Location) entry in the "More" menu as well? That would make sense as one can have same subnet in different location.

(BTW, I also have the same IP network, sometimes with different default gateways, in different subnets, which seems difficult for foreman to deal with).

additionally, you can do that today using the smart variables.

I'm afraid I can't as the subnet information is not part of any Fact. But as a noobs in smart variables I could have missed something. Anyway, SV are indeed interesting, thanks.

#4 Updated by Benjamin Papillon over 6 years ago

  • Description updated (diff)

Hello,

The subnet still don't have an additional parameter option but Foreman has much more options to manage your data than before.
Did you went around your issue?
Can I close this ticket?

Regards

#5 Updated by Dominic Cleal over 6 years ago

  • Related to Feature #4127: Array, Boolean and other types support in "hostgroup parameters" added

#6 Updated by Dominic Cleal over 6 years ago

As noted in #4127, I'd like to see domain/OS etc parameters replaced with the smart variables implementation so at least you could set overrides based on whatever object makes sense, rather than being limited to whatever we've added parameters to explicitly.

#7 Updated by Dominic Cleal over 6 years ago

  • Related to Bug #5204: support class parameters at the domain and OS levels. added

#8 Updated by Bryan Kearney over 4 years ago

  • Bugzilla link set to 1291935

#9 Updated by Tomer Brisker over 3 years ago

  • Status changed from Feedback to Duplicate

This has been resolved in #3582

#10 Updated by Tomer Brisker over 3 years ago

  • Is duplicate of Feature #3582: Allow Subnets to have Parameters like Domains added

Also available in: Atom PDF