Project

General

Profile

Feature #14762

hammer cannot manipulate content source on hosts.

Added by Michael Brown about 3 years ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
Difficulty:
medium
Triaged:
Yes
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Hammer cannot manipulate an individual hosts content source.

hammer hostgroup has

--content-source-id CONTENT_SOURCE_ID

There is no corresponding switch for content source for individual host objects. Manual workaround required. Need to manually set content source on each host object in the GUI.

It would be beneficial to be able to set an individual hosts content source via hammer cli commands for automation scripting and provisioning automation.


Related issues

Related to Foreman - Feature #16630: Need a way to extend existing apipie specificationClosed2016-09-21

History

#1 Updated by Tomáš Strachota almost 3 years ago

  • Project changed from Hammer CLI to Katello
  • Category changed from 74 to Hammer

#2 Updated by Justin Sherrill almost 3 years ago

  • Category changed from Hammer to API
  • Legacy Backlogs Release (now unused) set to 114
  • Difficulty set to medium

#3 Updated by Marek Hulán over 2 years ago

  • Related to Feature #16630: Need a way to extend existing apipie specification added

#4 Updated by Marek Hulán over 2 years ago

  • Status changed from New to Duplicate

I think this is duplicate of http://projects.theforeman.org/issues/7597 please reopen if you disagree.

Also available in: Atom PDF