Project

General

Profile

Refactor #14840

Support Ruby 2.3

Added by Michael Moll almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tests
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

As Ubuntu/xenial is bringing Ruby 2.3, all components should get tested also under Ruby 2.3 and new test failures fixed.


Related issues

Related to Smart Proxy - Bug #14461: Smart proxy fails to load any modules when running under ruby 2.3Closed2016-04-04
Related to Foreman - Refactor #15060: Support activerecord-session_store 1.xClosed2016-05-16
Blocks Packaging - Feature #14788: Ubuntu/xenial tracker issueClosed2016-04-22
Blocks Packaging - Feature #14809: Build RPMs for Fedora 24Closed2016-04-26

History

#1 Updated by Michael Moll almost 4 years ago

  • Related to Bug #14461: Smart proxy fails to load any modules when running under ruby 2.3 added

#2 Updated by Michael Moll almost 4 years ago

#3 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Closed
  • Assignee set to Dominic Cleal
  • Legacy Backlogs Release (now unused) changed from 136 to 155

Tests are already passing on develop and 1.11-stable, so I've added it to tests: https://github.com/theforeman/foreman-infra/commit/3a383860

#4 Updated by Dominic Cleal almost 4 years ago

#5 Updated by Dominic Cleal almost 4 years ago

Also available in: Atom PDF