Project

General

Profile

Bug #14862

Tests fail on Ruby <1.9.3 because of webmock version

Added by Michael Moll over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Tests
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

e.g. http://ci.theforeman.org/job/test_proxy_develop_pr_core/723/puppet=3.8.0,ruby=1.9.2/console

Installing rkerberos 0.1.3 with native extensions
Installing webmock 2.0.0

Gem::InstallError: webmock requires Ruby version >= 1.9.3.
Installing puppet 3.8.7
Installing sinatra 1.4.7
An error occurred while installing webmock (2.0.0), and Bundler cannot continue.
Make sure that `gem install webmock -v '2.0.0'` succeeds before bundling.
Build step 'Execute shell' marked build as failure

Associated revisions

Revision cfb732db (diff)
Added by Michael Moll over 3 years ago

Fixes #14862 - pin webmock version for Ruby <1.9.3

History

#1 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/smart-proxy/pull/411 added

#2 Updated by Michael Moll over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF