Project

General

Profile

Actions

Feature #149

closed

Better LDAP user control

Added by Eric Shamow over 14 years ago. Updated almost 14 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Currently when LDAP is enabled for login control, user auto-creation must be enabled to create new users. Alternately per Ohad the following line in app/controllers/users_controller.rb can be commented out:

config.actions.exclude :create

This feature should a) be controllable by the GUI, and b) should be expanded to allow users to specify a DN for an LDAP group to restrict access during autocreation.


Related issues 1 (0 open1 closed)

Is duplicate of Foreman - Feature #245: Fix LDAP user managementClosedEric Shamow05/11/2010Actions
Actions #1

Updated by Ohad Levy about 14 years ago

  • Target version set to 0.1-6
Actions #2

Updated by Ohad Levy almost 14 years ago

  • Status changed from New to Rejected
  • Target version deleted (0.1-6)
Actions

Also available in: Atom PDF