Project

General

Profile

Bug #1491

Fail to import new classes

Added by Romain Vrignaud over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Importers
Target version:
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

In debian nightly I get that error when I try to import new classes :

Processing EnvironmentsController#obsolete_and_new (for 192.168.200.29 at 2012-02-10 20:14:57) [POST]
Parameters: {"commit"=>"Update", "changed"=>{"new"=>{"production"=>"[\"munin::client::darwin\",\"munin::client::debian\",\"munin::client::redhat\",\"munin::snmp_collector\",\"nagios::contactgroups\",\"nagios::contacts\",\"nagios::host\",\"nagios::hostgroups\",\"nagios::service\"]", "development"=>"[\"munin::client::darwin\",\"munin::client::debian\",\"munin::client::redhat\",\"munin::snmp_collector\",\"nagios::contactgroups\",\"nagios::contacts\",\"nagios::host\",\"nagios::hostgroups\",\"nagios::service\",\"plop\"]", "preprod"=>"[\"\",\"munin::client::darwin\",\"munin::client::debian\",\"munin::client::redhat\",\"munin::snmp_collector\",\"nagios::contactgroups\",\"nagios::contacts\",\"nagios::host\",\"nagios::hostgroups\",\"nagios::service\"]", "test"=>"[\"munin::client::darwin\",\"munin::client::debian\",\"munin::client::redhat\",\"munin::snmp_collector\",\"nagios::contactgroups\",\"nagios::contacts\",\"nagios::host\",\"nagios::hostgroups\",\"nagios::service\"]"}}, "authenticity_token"=>"3Slfefr64QgtO+kPj3ek0Lz6Kn/eofSyQL5fynUj/Yg="}
can't convert ActiveRecord::Errors into Array
/usr/share/foreman/app/models/environment.rb:126:in `+'
/usr/share/foreman/app/models/environment.rb:126:in `obsolete_and_new'
/usr/share/foreman/app/models/environment.rb:123:in `each'
/usr/share/foreman/app/models/environment.rb:123:in `obsolete_and_new'
/usr/share/foreman/app/models/environment.rb:114:in `each'
/usr/share/foreman/app/models/environment.rb:114:in `obsolete_and_new'
/usr/share/foreman/lib/foreman/controller/environments.rb:19:in `obsolete_and_new'
Rendering template within layouts/application
Rendering common/500 (500)

I backported #1436.


Related issues

Is duplicate of Foreman - Bug #1496: puppet classes import error Duplicate2012-02-15

Associated revisions

Revision b9cb1001 (diff)
Added by Ohad Levy over 7 years ago

fixes #1491 - Fail to import new classes

History

#1 Updated by Ohad Levy over 7 years ago

  • Target version set to 1.0

#2 Updated by Ohad Levy over 7 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF