Project

General

Profile

Bug #14930

Update with --puppet-classes parameter will fail, if the classes belong to the same namespace

Added by Shimon Shtein over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:
In Kanboard:

Description

To reproduce:


hammer hostgroup update --id 5 --puppet-classes "apache::mod::authnz_ldap,apache::dev" 


will fail.

The problem is in the API response handling in id_resolver.rb
API response was grouped by namespace and validated groups count against number of classes in the requested parameters.

Associated revisions

Revision bb26bf42 (diff)
Added by Shimon Shtein over 4 years ago

Fixes #14930 - Fixed response parsing for puppetclasses parameter

History

#1 Updated by The Foreman Bot over 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/hammer-cli-foreman/pull/234 added

#2 Updated by Shimon Shtein over 4 years ago

  • Bugzilla link set to 1333280

#3 Updated by Shimon Shtein over 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF