Project

General

Profile

Bug #15006

Failed to send the host/guests json to Satellite 6.2

Added by Thomas McKay about 6 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1318984
Description of problem:
update Sat6.1 to Sat6.2, virt-who can't send the host/guests json to Sat6.2

Version-Release number of selected component (if applicable):
latest-stable-Satellite-6.2-RHEL-7
virt-who-0.16-7.el6.noarch
subscription-manager-1.16.8-4.el6.x86_64
python-rhsm-1.16.6-1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. register host to sat2 server
  1. subscription-manager register --username=admin --password=admin

2. configure virt-who for esx mode
VIRTWHO_ESX=1
VIRTWHO_ESX_OWNER=ACME_Corporation
VIRTWHO_ESX_ENV=Library
VIRTWHO_ESX_SERVER=10.73.2.95
VIRTWHO_ESX_USERNAME=
VIRTWHO_ESX_PASSWORD=Welcome1!

3. restart virt-who service and check rhsm.log
2016-03-18 18:21:08,718 [virtwho.init INFO] MainProcess(24746):MainThread @virtwho.py:main:729 - Using configuration "env/cmdline" ("esx" mode)
2016-03-18 18:21:08,732 [virtwho.main DEBUG] MainProcess(24749):MainThread @virtwho.py:run:231 - Starting infinite loop with 60 seconds interval
2016-03-18 18:21:08,840 [virtwho.env_cmdline DEBUG] Esx-1(24757):MainThread @virt.py:run:358 - Virt backend 'env/cmdline' started
2016-03-18 18:21:08,840 [virtwho.env_cmdline DEBUG] Esx-1(24757):MainThread @esx.py:_prepare:55 - Log into ESX
2016-03-18 18:21:09,176 [virtwho.env_cmdline DEBUG] Esx-1(24757):MainThread @esx.py:_prepare:58 - Creating ESX event filter
2016-03-18 18:21:09,324 [virtwho.env_cmdline DEBUG] Esx-1(24757):MainThread @virt.py:enqueue:351 - Report for config "env/cmdline" gathered, putting to queue for sending
2016-03-18 18:21:09,335 [virtwho.main DEBUG] MainProcess(24749):MainThread @subscriptionmanager.py:_connect:121 - Authenticating with certificate: /etc/pki/consumer/cert.pem
2016-03-18 18:21:09,570 [virtwho.main DEBUG] MainProcess(24749):MainThread @subscriptionmanager.py:hypervisorCheckIn:162 - Checking if server has capability 'hypervisor_async'
2016-03-18 18:21:09,749 [virtwho.main DEBUG] MainProcess(24749):MainThread @subscriptionmanager.py:hypervisorCheckIn:174 - Server does not have 'hypervisors_async' capability
2016-03-18 18:21:09,749 [virtwho.main INFO] MainProcess(24749):MainThread @subscriptionmanager.py:hypervisorCheckIn:185 - Sending update in hosts-to-guests mapping for config "env/cmdline": 1 hypervisors and 1 guests found
2016-03-18 18:21:09,749 [virtwho.main DEBUG] MainProcess(24749):MainThread @subscriptionmanager.py:hypervisorCheckIn:186 - Host-to-guest mapping: {
"3e504d56-3982-037b-f3e6-669289892fa1": [ {
"guestId": "4206405a-4133-bd0c-f8a5-9c7bc1355837",
"state": 1,
"attributes": {
"active": 1,
"hypervisorVersion": "6.0.0",
"virtWhoType": "esx",
"hypervisorType": "VMware ESXi"
}
}
]
}
2016-03-18 18:21:10,654 [virtwho.main ERROR] MainProcess(24749):MainThread @virtwho.py:send:203 - Unable to send data: Communication with subscription manager failed with code 500: Task 7f83497c-9dcf-4a0f-8b3e-56b3b29cdd73: TypeError: can't cast ActiveSupport::HashWithIndifferentAccess to string
2016-03-18 18:21:10,654 [virtwho.main DEBUG] MainProcess(24749):MainThread @virtwho.py:send_report:168 - Report from "env/cmdline" failed to sent

Actual results:
Unable to send data: Communication with subscription manager failed with code 500: Task 7f83497c-9dcf-4a0f-8b3e-56b3b29cdd73: TypeError: can't cast ActiveSupport::HashWithIndifferentAccess to string

Expected results:
virt-who should send the json data to satellite6.2 normally.

Additional info:

History

#1 Updated by Eric Helms about 6 years ago

  • Legacy Backlogs Release (now unused) set to 143

#2 Updated by Justin Sherrill almost 6 years ago

  • Status changed from New to Rejected
  • Legacy Backlogs Release (now unused) changed from 143 to 166

This seems to be resolved at some point likely by https://github.com/Katello/katello/pull/6039

Also available in: Atom PDF